summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2008-02-21 17:30:55 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2008-02-21 17:30:55 +0000
commitb448456003a19e192251035b5c8c048a0cdc9085 (patch)
tree1c2b3497d2990352cb36c88c308a3f1450130fcf /media-libs/gmyth/gmyth-0.7.ebuild
parentFix caps failure wrt #210478 (diff)
downloadhistorical-b448456003a19e192251035b5c8c048a0cdc9085.tar.gz
historical-b448456003a19e192251035b5c8c048a0cdc9085.tar.bz2
historical-b448456003a19e192251035b5c8c048a0cdc9085.zip
initial commit
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'media-libs/gmyth/gmyth-0.7.ebuild')
-rw-r--r--media-libs/gmyth/gmyth-0.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/gmyth/gmyth-0.7.ebuild b/media-libs/gmyth/gmyth-0.7.ebuild
new file mode 100644
index 000000000000..975844da9c26
--- /dev/null
+++ b/media-libs/gmyth/gmyth-0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gmyth/gmyth-0.7.ebuild,v 1.1 2008/02/21 17:30:55 zaheerm Exp $
+
+inherit libtool
+
+IUSE="debug"
+LICENSE="LGPL-2"
+DESCRIPTION="GObject based library to access mythtv backends"
+HOMEPAGE="http://gmyth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gmyth/${PN}_${PV}-indt1.tar.gz"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+RDEPEND="net-misc/curl
+ dev-libs/glib
+ dev-libs/libxml2
+ virtual/mysql"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ econf $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}
+