summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-02-04 08:19:43 +0000
committerDavid Holm <dholm@gentoo.org>2005-02-04 08:19:43 +0000
commit7c84b5e6203b36f61002df114b7c84344b6ab3e5 (patch)
treecd6856c50552c31a0474eabcd72f632fbcd00965 /media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
parentFixed skinbrowser bug, added wheelscroll patch and cdplay patches. (diff)
downloadhistorical-7c84b5e6203b36f61002df114b7c84344b6ab3e5.tar.gz
historical-7c84b5e6203b36f61002df114b7c84344b6ab3e5.tar.bz2
historical-7c84b5e6203b36f61002df114b7c84344b6ab3e5.zip
Version bumped and added to ~ppc
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'media-libs/atlas-c++/atlas-c++-0.5.92.ebuild')
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.5.92.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
new file mode 100644
index 000000000000..80f66f62be92
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild,v 1.1 2005/02/04 08:19:43 dholm Exp $
+
+inherit eutils
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Atlas protocol standard implementation in C++. Atlas protocol is used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.net"
+SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=dev-libs/libsigc++-1.2*"
+
+src_install() {
+ make DESTDIR=${D} install || die
+ #dodoc will install all these docs and a few more
+ rm -rf ${D}/usr/share/doc/${My_P}
+ #PR=r0 in this case, but don't fprget to add ${PR} here for non-zero revisions!
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README ROADMAP THANKS TODO
+}