summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-10-11 16:16:01 +0000
committerMarkus Meier <maekke@gentoo.org>2008-10-11 16:16:01 +0000
commitf7437d1537b42a3e2385b5a69631648414efc0c8 (patch)
tree23aacbcc86ea13e0dc17bc5e4aea41519256fbaf /media-gfx/tic98/tic98-1.01-r3.ebuild
parentFix broken Manifest, bug #241216. Remove leftover patch from filesdir. (diff)
downloadhistorical-f7437d1537b42a3e2385b5a69631648414efc0c8.tar.gz
historical-f7437d1537b42a3e2385b5a69631648414efc0c8.tar.bz2
historical-f7437d1537b42a3e2385b5a69631648414efc0c8.zip
respect CFLAGS and LDFLAGS, bug #240804
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-rc9 i686
Diffstat (limited to 'media-gfx/tic98/tic98-1.01-r3.ebuild')
-rw-r--r--media-gfx/tic98/tic98-1.01-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/tic98/tic98-1.01-r3.ebuild b/media-gfx/tic98/tic98-1.01-r3.ebuild
new file mode 100644
index 000000000000..9c68bb4d724c
--- /dev/null
+++ b/media-gfx/tic98/tic98-1.01-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tic98/tic98-1.01-r3.ebuild,v 1.1 2008/10/11 16:16:01 maekke Exp $
+
+inherit eutils
+
+DESCRIPTION="compressor for black-and-white images, in particular scanned documents"
+HOMEPAGE="http://membled.com/work/mirror/tic98/"
+SRC_URI="http://membled.com/work/mirror/tic98/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-macos.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+
+ # respect CFLAGS and LDFLAGS
+ sed -i -e "s:CFLAGS= -O -Wall -Wno-unused:CFLAGS=${CFLAGS}:" \
+ -e "s:LIBS= -lm #-L/home/singlis/linux/lib -lccmalloc -ldl:LIBS= -lm ${LDFLAGS}:" \
+ Makefile || die
+}
+
+src_compile() {
+ emake all || die
+ emake all2 || die
+}
+
+src_install() {
+ dodir /usr/bin
+ emake BIN="${D}"usr/bin install || die
+
+ # collision with media-gfx/netpbm, see bug #207534
+ rm "${D}"/usr/bin/pbmclean || die
+}