summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2006-07-31 07:22:12 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2006-07-31 07:22:12 +0000
commitf3171ea26e5d4b6a12e638366d52ee09e2f1537f (patch)
treed3fcbcb319dd68119b5306509b2a0d05c163c10f /media-gfx/sane-backends
parentinitial commit - ebuild submitted by Leszek via bug #130461 (diff)
downloadhistorical-f3171ea26e5d4b6a12e638366d52ee09e2f1537f.tar.gz
historical-f3171ea26e5d4b6a12e638366d52ee09e2f1537f.tar.bz2
historical-f3171ea26e5d4b6a12e638366d52ee09e2f1537f.zip
Fix for overlong comments in the udev rules added, bug #142052
Package-Manager: portage-2.1
Diffstat (limited to 'media-gfx/sane-backends')
-rw-r--r--media-gfx/sane-backends/ChangeLog9
-rw-r--r--media-gfx/sane-backends/files/digest-sane-backends-1.0.18-r26
-rw-r--r--media-gfx/sane-backends/files/udev-rule.patch44
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.18-r2.ebuild138
4 files changed, 196 insertions, 1 deletions
diff --git a/media-gfx/sane-backends/ChangeLog b/media-gfx/sane-backends/ChangeLog
index 09c050f03a2e..fb7a00fe82f5 100644
--- a/media-gfx/sane-backends/ChangeLog
+++ b/media-gfx/sane-backends/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/sane-backends
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.101 2006/07/28 09:12:14 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.102 2006/07/31 07:22:12 phosphan Exp $
+
+*sane-backends-1.0.18-r2 (31 Jul 2006)
+
+ 31 Jul 2006; Patrick Kursawe <phosphan@gentoo.org>
+ -files/scsi-udev-rule.patch, +files/udev-rule.patch,
+ -sane-backends-1.0.18-r1.ebuild, +sane-backends-1.0.18-r2.ebuild:
+ Fix for overlong comments in the udev rules added, bug #142052
*sane-backends-1.0.18-r1 (28 Jul 2006)
diff --git a/media-gfx/sane-backends/files/digest-sane-backends-1.0.18-r2 b/media-gfx/sane-backends/files/digest-sane-backends-1.0.18-r2
new file mode 100644
index 000000000000..5242a0c5bacf
--- /dev/null
+++ b/media-gfx/sane-backends/files/digest-sane-backends-1.0.18-r2
@@ -0,0 +1,6 @@
+MD5 69b18ea038b8cd0e289c04c512b43b8e sane-1.0.18-brother-driver.diff.bz2 8335
+RMD160 8d86dccca4054699e367412c25d80d8641de42ca sane-1.0.18-brother-driver.diff.bz2 8335
+SHA256 4a2eceb222f6cd55979fd150c4a7c365a9a83f2beab15045852f8859404de23b sane-1.0.18-brother-driver.diff.bz2 8335
+MD5 7ca7e2908e24721471de92cf40c75e60 sane-backends-1.0.18.tar.gz 3789493
+RMD160 aa863adff417d7c33cbb85c193878aa54a056100 sane-backends-1.0.18.tar.gz 3789493
+SHA256 d7876a78c5676b0c4bc29091c7a7e1287b5c0be5ff5bb61ef033fbffc73d66f3 sane-backends-1.0.18.tar.gz 3789493
diff --git a/media-gfx/sane-backends/files/udev-rule.patch b/media-gfx/sane-backends/files/udev-rule.patch
new file mode 100644
index 000000000000..894f47e6677f
--- /dev/null
+++ b/media-gfx/sane-backends/files/udev-rule.patch
@@ -0,0 +1,44 @@
+--- tools/sane-desc.c 2006-07-31 08:57:40.000000000 +0200
++++ tools/sane-desc-new.c 2006-07-31 09:10:50.000000000 +0200
+@@ -3151,7 +3151,7 @@
+
+ printf
+ ("#\n"
+- "# udev rules file for supported USB devices\n"
++ "# udev rules file for supported USB and SCSI devices\n"
+ "#\n"
+ "# To add a USB device, add a rule to the list below between the SUBSYSTEM...\n"
+ "# and LABEL... lines.\n"
+@@ -3169,21 +3169,28 @@
+ static void
+ print_udev (void)
+ {
++ int commentlen;
+ usbid_type *usbid = create_usbids_table ();
+
+ print_udev_header ();
+ printf ("\nACTION!=\"add\", GOTO=\"libsane_rules_end\"\n");
++ puts("BUS==\"scsi\", SYSFS{type}==\"6\", MODE=\"660\", GROUP=\"scanner\"");
+ printf ("SUBSYSTEM!=\"usb_device\", GOTO=\"libsane_rules_end\"\n\n");
+ while (usbid)
+ {
+ manufacturer_model_type * name = usbid->name;
+
+- printf ("# ");
++ commentlen = printf ("# ");
+ while (name)
+ {
+- if (name != usbid->name)
+- printf (" | ");
+- printf ("%s", name->name);
++ if (name != usbid->name) {
++ commentlen += printf (" | ");
++ }
++ if(commentlen + strlen(name->name) > 480) {
++ printf(" (line too long, names omitted)");
++ break;
++ }
++ commentlen += printf ("%s", name->name);
+ name = name->next;
+ }
+ printf ("\n");
diff --git a/media-gfx/sane-backends/sane-backends-1.0.18-r2.ebuild b/media-gfx/sane-backends/sane-backends-1.0.18-r2.ebuild
new file mode 100644
index 000000000000..4a95c531a078
--- /dev/null
+++ b/media-gfx/sane-backends/sane-backends-1.0.18-r2.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.18-r2.ebuild,v 1.1 2006/07/31 07:22:12 phosphan Exp $
+
+inherit eutils
+
+IUSE="usb gphoto2 ipv6 v4l"
+
+DESCRIPTION="Scanner Access Now Easy - Backends"
+HOMEPAGE="http://www.sane-project.org/"
+
+RDEPEND=">=media-libs/jpeg-6b
+ amd64? ( sys-libs/libieee1284 )
+ x86? ( sys-libs/libieee1284 )
+ usb? ( >=dev-libs/libusb-0.1.8 )
+ gphoto2? ( media-libs/libgphoto2 )
+ v4l? ( sys-kernel/linux-headers )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+BROTHERMFCPATCHVER="1.0.18"
+BROTHERMFCDRIVER="sane-${BROTHERMFCPATCHVER}-brother-driver.diff"
+
+# Could not access via ftp on 2006-07-20
+SRC_URI="http://alioth.debian.org/download.php/1669/sane-backends-1.0.18.tar.gz
+ ftp://ftp.sane-project.org/pub/sane/${P}/${P}.tar.gz
+ ftp://ftp.sane-project.org/pub/sane/old-versions/${P}/${P}.tar.gz
+ usb? ( mirror://gentoo/${BROTHERMFCDRIVER}.bz2
+ http://dev.gentoo.org/~phosphan/${BROTHERMFCDRIVER}.bz2 )"
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# To enable specific backends, define SANE_BACKENDS with the backends you want
+# in those:
+#
+# abaton agfafocus apple artec as6e avision bh brother canon
+# canon630u coolscan coolscan2 dc25 dmc
+# epson fujitsu genesys gt68xx hp leo lexmark matsushita microtek
+# microtek2 mustek mustek_usb nec pie pixma plustek
+# plustek_pp ricoh s9036 sceptre sharp
+# sp15c st400 tamarack test teco1 teco2 teco3 umax umax_pp umax1220u
+# artec_eplus48u ma1509 ibm hp5400 u12 snapscan niash sm3840 hp4200
+# sm3600 hp3500 stv680"
+
+# Note that some backends has specific dependencies which make the compilation
+# fail because not supported on your current platform.
+
+pkg_setup() {
+ enewgroup scanner
+
+ IEEE1284_BACKENDS="canon_pp hpsj5s mustek_pp"
+
+ if [[ "${SANE_BACKENDS}" != "" ]]; then
+ use gphoto2 && SANE_BACKENDS="${SANE_BACKENDS} gphoto2"
+ use v4l && SANE_BACKENDS="${SANE_BACKENDS} v4l"
+ use usb && SANE_BACKENDS="${SANE_BACKENDS} sm3600"
+ fi
+
+ if ! use x86 && ! use amd64; then
+ tmp="${SANE_BACKENDS}"
+ for backend in ${IEEE1284_BACKENDS}; do
+ if [[ "${tmp/$backend/}" != "${SANE_BACKENDS}" ]]; then
+ ewarn "You selected a backend which is disabled because it's not usable in your arch."
+ fi
+ done
+ fi
+}
+
+src_unpack() {
+ if [ -z "${SANE_BACKENDS}" ]; then
+ einfo "You can use the variable SANE_BACKENDS to pick backends"
+ einfo "instead of building all of them."
+ fi
+ unpack ${A}
+ if use usb; then
+ unpack ${BROTHERMFCDRIVER}.bz2
+ fi
+
+ cd ${S}
+
+ #only generate the .ps and not the fonts
+ sed -i -e 's:$(DVIPS) sane.dvi -o sane.ps:$(DVIPS) sane.dvi -M1 -o sane.ps:' \
+ doc/Makefile.in
+
+ if use usb; then
+ epatch ${WORKDIR}/${BROTHERMFCDRIVER}
+ sed -e 's/bh canon/bh brother canon/' -i configure || \
+ die "could not add 'brother' to backend list"
+ fi
+ epatch ${FILESDIR}/udev-rule.patch
+}
+
+src_compile() {
+ SANEI_JPEG="sanei_jpeg.o" SANEI_JPEG_LO="sanei_jpeg.lo" \
+ BACKENDS="${SANE_BACKENDS}" \
+ econf \
+ $(use_enable usb libusb) \
+ $(use_with gphoto2) \
+ $(use_enable ipv6) \
+ ${myconf} || die "econf failed"
+
+ emake || die
+
+ if use usb; then
+ cd tools/hotplug
+ grep -v '^$' libsane.usermap > libsane.usermap.new
+ mv libsane.usermap.new libsane.usermap
+ fi
+}
+
+src_install () {
+ make INSTALL_LOCKPATH="" DESTDIR="${D}" install \
+ docdir=/usr/share/doc/${PF}
+ keepdir /var/lib/lock/sane
+ fowners root:scanner /var/lib/lock/sane
+ fperms g+w /var/lib/lock/sane
+ dodir /etc/env.d
+ if use usb; then
+ cd tools/hotplug
+ insinto /etc/hotplug/usb
+ exeinto /etc/hotplug/usb
+ doins libsane.usermap
+ doexe libusbscanner
+ newdoc README README.hotplug
+ echo >> ${D}/etc/env.d/30sane "USB_DEVFS_PATH=/dev/bus/usb"
+ cd ../..
+ fi
+ cd tools/udev
+ dodir /etc/udev/rules.d
+ insinto /etc/udev/rules.d
+ newins libsane.rules 99-libsane.rules
+ cd ../..
+
+ dodoc NEWS AUTHORS LICENSE ChangeLog* README README.linux
+ echo "SANE_CONFIG_DIR=/etc/sane.d" >> ${D}/etc/env.d/30sane
+}