summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-05-05 03:09:18 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-05-05 03:09:18 +0000
commitd880411268a4918fa0c1f5e5c6b0b7a9754dcdf1 (patch)
tree791586df9c77c08e1f07a60b30f6c3646949368a /media-gfx/maya/maya-5.0.1-r1.ebuild
parentcorrect desc of gcj (bug #50058) (diff)
downloadhistorical-d880411268a4918fa0c1f5e5c6b0b7a9754dcdf1.tar.gz
historical-d880411268a4918fa0c1f5e5c6b0b7a9754dcdf1.tar.bz2
historical-d880411268a4918fa0c1f5e5c6b0b7a9754dcdf1.zip
Now using cdrom_get_cds if MAYA_INSTALL_LOC is not set. Closes bug #49765.
Diffstat (limited to 'media-gfx/maya/maya-5.0.1-r1.ebuild')
-rw-r--r--media-gfx/maya/maya-5.0.1-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-gfx/maya/maya-5.0.1-r1.ebuild b/media-gfx/maya/maya-5.0.1-r1.ebuild
index 2fcf51934e7b..bc18597a839d 100644
--- a/media-gfx/maya/maya-5.0.1-r1.ebuild
+++ b/media-gfx/maya/maya-5.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/maya/maya-5.0.1-r1.ebuild,v 1.3 2004/05/02 02:33:43 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/maya/maya-5.0.1-r1.ebuild,v 1.4 2004/05/05 03:09:18 eradicator Exp $
# Note that this ebuild requires you to set the MAYA_INSTALL_LOC environment
# variable to the location of your maya RPMS and documentation:
@@ -17,7 +17,7 @@
# lrwxr-xr-x 1 root root 16 Apr 2 2003 shaderLibrary -> ../shaderLibrary
# drwxr-xr-x 3 root root 2048 Apr 2 2003 support
-inherit rpm
+inherit rpm eutils
IUSE="bundled-libs"
S="${WORKDIR}"
@@ -63,7 +63,8 @@ pkg_nofetch() {
src_unpack() {
if [ -z "${MAYA_INSTALL_LOC}" ]; then
- MAYA_INSTALL_LOC=/mnt/cdrom/LINUX
+ cdrom_get_cds LINUX/AWCommon-${AWCOMMON}.rpm
+ MAYA_INSTALL_LOC=${CDROM_ROOT}/LINUX
fi
if [ ! -d "${MAYA_INSTALL_LOC}" ]; then