summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-09 04:01:51 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-09 04:01:51 +0000
commit1bb0dc45de5f514631292fcf02967a389f873883 (patch)
tree2e9e0bee6b0fc7206af73c0be70396ab4e27a77e /media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild
parentInitial Import (diff)
downloadhistorical-1bb0dc45de5f514631292fcf02967a389f873883.tar.gz
historical-1bb0dc45de5f514631292fcf02967a389f873883.tar.bz2
historical-1bb0dc45de5f514631292fcf02967a389f873883.zip
added a patch to fix a segfault on amd64 - see bug #46981 for more info
Diffstat (limited to 'media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild')
-rw-r--r--media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild b/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild
new file mode 100644
index 000000000000..305160cbcf77
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild,v 1.1 2004/04/09 04:01:51 lv Exp $
+
+MY_P="${P}.0"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Quick and useful plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+
+LICENSE="gnuplot"
+SLOT="0"
+KEYWORDS="-x86 -ppc -sparc -alpha amd64 -ia64"
+IUSE="X readline svga plotutils pdflib doc"
+
+# Old png driver seems to have problems; switching to gd instead
+DEPEND=">=media-libs/libgd-2
+ pdflib? ( media-libs/pdflib )
+ doc? ( virtual/tetex )
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ readline? ( sys-libs/readline )
+ plotutils? ( media-libs/plotutils )"
+
+src_unpack() {
+ unpack ${A}
+ use amd64 && (cd ${S} ; epatch ${FILESDIR}/gnuplot-3.8j-amd64.diff)
+}
+
+src_compile() {
+ local myconf
+ #--with-lasergnu flag seems to be broken and I'm too lazy to fix now
+ #myconf=" --with-png --without-gd --with-lasergnu"
+ myconf=" --with-gd --with-plot=/usr/lib"
+ #--with-plot enables the Gnu plotutils library
+ #need to specify path to differentiate from Unix plot
+
+ use plotutils \
+ && myconf="${myconf} --with-plot=/usr/lib" \
+ || myconf="${myconf} --without-plot"
+
+ myconf="${myconf} `use_with pdflib pdf`"
+ myconf="${myconf} `use_with X x`"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu" \
+ || myconf="${myconf} --with-readline"
+
+ myconf="${myconf} `use_with svga vga`"
+
+ econf \
+ --datadir=/usr/share/gnuplot \
+ ${myconf} || die
+
+ cd ${S}
+ emake || die
+
+ if [ -n "`use doc`" ] ; then
+ cd docs
+ make pdf || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc 0* ChangeLog CodeStyle Copyright NEWS PGPKEYS TODO
+ use doc && dodoc docs/gnuplot.pdf
+}
+
+pkg_postinst() {
+ if [ "`use svga`" ] ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually chmod u+s /usr/bin/gnuplot"
+ fi
+}