summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-11-10 13:23:29 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-11-10 13:23:29 +0000
commit5413c61df051ef8e5c59465c3f9003c55a805856 (patch)
treea0a0e56c3768ce652548b0b26d714e9549c15b4c /media-gfx/digikam/files
parentkeyword ~ppc ~ppc64, bug #442040 (diff)
downloadhistorical-5413c61df051ef8e5c59465c3f9003c55a805856.tar.gz
historical-5413c61df051ef8e5c59465c3f9003c55a805856.tar.bz2
historical-5413c61df051ef8e5c59465c3f9003c55a805856.zip
Remove old; add trivial patch for mariadb-5.5, bug 441566
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0xB6C5F7DE
Diffstat (limited to 'media-gfx/digikam/files')
-rw-r--r--media-gfx/digikam/files/digikam-2.5.0-boost148.patch74
-rw-r--r--media-gfx/digikam/files/digikam-2.5.0-libkipi.patch75
-rw-r--r--media-gfx/digikam/files/digikam-2.9.0-mariadb55.patch12
3 files changed, 12 insertions, 149 deletions
diff --git a/media-gfx/digikam/files/digikam-2.5.0-boost148.patch b/media-gfx/digikam/files/digikam-2.5.0-boost148.patch
deleted file mode 100644
index 81198397ab80..000000000000
--- a/media-gfx/digikam/files/digikam-2.5.0-boost148.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-commit d18ea6da2d3e2359f4113e83c3fd40c18a29ddab
-Author: Gilles Caulier <caulier.gilles@gmail.com>
-Date: Fri Jan 6 11:23:48 2012 +0100
-
- Apply patch #67483 from Jeremiah Willcock to compile fine digiKam boost graph interface with libboost 1.48
- BUGS: 287772
- CCBUGS: 267777
-
-diff --git a/libs/database/imagehistory/imagehistorygraph_boost.h b/libs/database/imagehistory/imagehistorygraph_boost.h
-index 4017c4f..76c764a 100644
---- a/libs/database/imagehistory/imagehistorygraph_boost.h
-+++ b/libs/database/imagehistory/imagehistorygraph_boost.h
-@@ -1198,7 +1198,7 @@ protected:
- {
- boost::dag_shortest_paths(graph, v,
- // we provide a constant weight of 1
-- weight_map(boost::ref_property_map<edge_t,int>(weight)).
-+ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
- // Store distance and predecessors in QMaps, wrapped to serve as property maps
- distance_map(VertexIntMapAdaptor(distances)).
- predecessor_map(VertexVertexMapAdaptor(predecessors))
-@@ -1218,7 +1218,7 @@ protected:
- {
- boost::dag_shortest_paths(graph, v,
- // we provide a constant weight of 1
-- weight_map(boost::ref_property_map<edge_t,int>(weight)).
-+ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
- // Invert the default compare method: With greater, we get the longest path
- distance_compare(std::greater<int>()).
- // will be returned if a node is unreachable
-@@ -1384,14 +1384,15 @@ protected:
- template <class GraphType, typename VertexLessThan>
- class lessThanMapEdgeToTarget
- {
-+ typedef typename boost::graph_traits<GraphType>::edge_descriptor edge_descriptor;
- public:
- lessThanMapEdgeToTarget(const GraphType& g, VertexLessThan vertexLessThan)
- : g(g), vertexLessThan(vertexLessThan) {}
- const GraphType& g;
- VertexLessThan vertexLessThan;
-- bool operator()(const Edge& a, const Edge& b)
-+ bool operator()(const edge_descriptor& a, const edge_descriptor& b)
- {
-- return vertexLessThan(boost::target(a.toEdge(), g), boost::target(b.toEdge(), g));
-+ return vertexLessThan(boost::target(a, g), boost::target(b, g));
- }
- };
-
-@@ -1402,20 +1403,21 @@ protected:
- {
- typedef std::pair<Vertex, QList<Edge> > VertexInfo;
-
-- QList<Edge> outEdges;
-+ typedef typename boost::graph_traits<IncidenceGraph>::edge_descriptor edge_descriptor;
-+ QList<edge_descriptor> outEdges;
- std::vector<VertexInfo> stack;
-
- boost::put(color, u, boost::gray_color);
- vis.discover_vertex(u, g);
-
-- outEdges = toEdgeList(boost::out_edges(u, g));
-+ outEdges = toList<edge_descriptor>(boost::out_edges(u, g));
- // Sort edges. The lessThan we have takes vertices, so we use a lessThan which
- // maps the given edges to their targets, and calls our vertex lessThan.
- qSort(outEdges.begin(), outEdges.end(), lessThanMapEdgeToTarget<IncidenceGraph, LessThan>(g, lessThan));
-
-- foreach(const Edge& e, outEdges)
-+ foreach(const edge_descriptor& e, outEdges)
- {
-- Vertex v = boost::target(e.toEdge(), g);
-+ Vertex v = boost::target(e, g);
- vis.examine_edge(e, g);
- boost::default_color_type v_color = boost::get(color, v);
- if (v_color == boost::white_color)
diff --git a/media-gfx/digikam/files/digikam-2.5.0-libkipi.patch b/media-gfx/digikam/files/digikam-2.5.0-libkipi.patch
deleted file mode 100644
index fbbac97a9489..000000000000
--- a/media-gfx/digikam/files/digikam-2.5.0-libkipi.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From 25cc9c9876a5233bd630105d0110319892d4e18c Mon Sep 17 00:00:00 2001
-From: Gilles Caulier <caulier.gilles@gmail.com>
-Date: Tue, 3 Jan 2012 15:16:37 +0100
-Subject: [PATCH] enable checkall and clearall buttons only with libkipi version 1.4.0
- BUGS: 290496
-
----
- utilities/setup/setupplugins.cpp | 13 +++++++++++--
- utilities/setup/setupplugins.h | 4 ++--
- 2 files changed, 13 insertions(+), 4 deletions(-)
-
-diff --git a/utilities/setup/setupplugins.cpp b/utilities/setup/setupplugins.cpp
-index 0f4030a..b8efb35 100644
---- a/utilities/setup/setupplugins.cpp
-+++ b/utilities/setup/setupplugins.cpp
-@@ -6,8 +6,8 @@
- * Date : 2004-01-02
- * Description : setup Kipi plugins tab.
- *
-- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
-- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
-+ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
-+ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
- *
- * This program is free software; you can redistribute it
- * and/or modify it under the terms of the GNU General
-@@ -100,6 +100,11 @@ SetupPlugins::SetupPlugins(QWidget* parent)
-
- panel->setLayout(mainLayout);
-
-+#if KIPI_VERSION < 0x010400
-+ d->checkAllBtn->setVisible(false);
-+ d->clearBtn->setVisible(false);
-+#endif
-+
- initPlugins();
-
- // --------------------------------------------------------
-@@ -158,14 +163,18 @@ void SetupPlugins::applyPlugins()
- void SetupPlugins::slotCheckAll()
- {
- QApplication::setOverrideCursor(Qt::WaitCursor);
-+#if KIPI_VERSION >= 0x010400
- d->kipiConfig->slotCheckAll();
-+#endif
- QApplication::restoreOverrideCursor();
- }
-
- void SetupPlugins::slotClear()
- {
- QApplication::setOverrideCursor(Qt::WaitCursor);
-+#if KIPI_VERSION >= 0x010400
- d->kipiConfig->slotClear();
-+#endif
- QApplication::restoreOverrideCursor();
- }
-
-diff --git a/utilities/setup/setupplugins.h b/utilities/setup/setupplugins.h
-index 271a569..114e0fa 100644
---- a/utilities/setup/setupplugins.h
-+++ b/utilities/setup/setupplugins.h
-@@ -6,8 +6,8 @@
- * Date : 2004-01-02
- * Description : setup Kipi plugins tab.
- *
-- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
-- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
-+ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
-+ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
- *
- * This program is free software; you can redistribute it
- * and/or modify it under the terms of the GNU General
---
-1.7.3.4
-
diff --git a/media-gfx/digikam/files/digikam-2.9.0-mariadb55.patch b/media-gfx/digikam/files/digikam-2.9.0-mariadb55.patch
new file mode 100644
index 000000000000..7b896fe7246e
--- /dev/null
+++ b/media-gfx/digikam/files/digikam-2.9.0-mariadb55.patch
@@ -0,0 +1,12 @@
+diff -ruN digikam-2.9.0.orig/core/CMakeLists.txt digikam-2.9.0/core/CMakeLists.txt
+--- digikam-2.9.0.orig/core/CMakeLists.txt 2012-09-02 12:38:13.000000000 +0200
++++ digikam-2.9.0/core/CMakeLists.txt 2012-11-10 14:20:11.000000000 +0100
+@@ -288,7 +288,7 @@
+ # under MACOS-X, through macports project, mysql_install_db PERL script is named "mysql_install_db5"
+ FIND_PROGRAM( INITCMD_MYSQL mysql_install_db mysql_install_db5 mysql_install_db.pl
+ PATHS /usr/sbin /usr/local/sbin /usr/libexec /usr/local/libexec
+- /opt/mysql/libexec /usr/mysql/bin /opt/mysql/bin ${MYSQL_TOOLS_PATH}
++ /opt/mysql/libexec /usr/mysql/bin /opt/mysql/bin /usr/share/mysql/scripts ${MYSQL_TOOLS_PATH}
+ ENV MYSQL_TOOLS_PATH )
+ MESSAGE(STATUS "Found MySQL install_db executable at: ${INITCMD_MYSQL}")
+ SET(DATABASESERVERDIR "${CMAKE_CURRENT_SOURCE_DIR}/databaseserver")