summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-01-11 21:04:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-01-11 21:04:52 +0000
commitba68f6ffb336650b236f8753ece1869028fd4b35 (patch)
treed8b80aa8e6d907bc86b3e3eaa19dd6e143020fbd /media-fonts/artwiz-fonts/artwiz-fonts-2.4-r2.ebuild
parentFixes for modular-X, and support for parallel building (the Makefile is clean). (diff)
downloadhistorical-ba68f6ffb336650b236f8753ece1869028fd4b35.tar.gz
historical-ba68f6ffb336650b236f8753ece1869028fd4b35.tar.bz2
historical-ba68f6ffb336650b236f8753ece1869028fd4b35.zip
Fix DEPEND/RDEPEND for modular-X.
Package-Manager: portage-2.0.54
Diffstat (limited to 'media-fonts/artwiz-fonts/artwiz-fonts-2.4-r2.ebuild')
-rw-r--r--media-fonts/artwiz-fonts/artwiz-fonts-2.4-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-fonts/artwiz-fonts/artwiz-fonts-2.4-r2.ebuild b/media-fonts/artwiz-fonts/artwiz-fonts-2.4-r2.ebuild
new file mode 100644
index 000000000000..eb56d659454e
--- /dev/null
+++ b/media-fonts/artwiz-fonts/artwiz-fonts-2.4-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/artwiz-fonts/artwiz-fonts-2.4-r2.ebuild,v 1.1 2006/01/11 21:01:43 robbat2 Exp $
+
+S="${WORKDIR}/xfonts-artwiz-2.3"
+DESCRIPTION="Artwiz Fonts"
+SRC_URI="http://ftp.debian.org/debian/pool/main/x/xfonts-artwiz/xfonts-artwiz_${PV}.tar.gz"
+HOMEPAGE="http://fluxbox.sourceforge.net/docs/artwiz-fonts.php"
+
+SLOT=0
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="|| ( x11-apps/bdftopcf virtual/x11 )
+ x11-apps/ttmkfdir"
+RDEPEND=""
+
+src_compile() {
+ cd ${S}/upstream
+ for font in *.bdf; do
+ /usr/X11R6/bin/bdftopcf ${font} > `basename $font .bdf`.pcf
+ done
+ gzip *.pcf
+}
+
+src_install() {
+ cd ${S}/upstream
+ rm cursor.pcf.gz
+
+ insopts -m0644
+ insinto /usr/share/fonts/artwiz/
+ doins *.pcf.gz
+
+ cd ${S}/debian
+ insopts -m0644
+ insinto /usr/share/fonts/artwiz/
+ doins fonts.alias
+
+# These don't get downloaded because there is no simple way to
+# fetch them.. ie if I included the README in SRC_URI above, it would
+# get saved as /usr/portage/distfiles/README which doesn't seem like
+# a really good idea.
+ dodoc ../COPYING
+
+ if [ -z "$(grep artwiz /etc/X11/fs/config)" ]
+ then
+ sed 's#^catalog.*$#&\n\t/usr/share/fonts/artwiz:unscaled,#g' \
+ /etc/X11/fs/config > ${S}/config
+ insinto /etc/X11/fs
+ doins config
+ fi
+
+}
+
+pkg_postinst() {
+ einfo ">>> Making font dirs..."
+ cd /usr/share/fonts/artwiz
+ mkfontdir
+}