summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-10-17 17:37:59 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-10-17 17:37:59 +0000
commitb0f6f970e30c397987c32242cb53cfb8f9a332a4 (patch)
tree62adc8b301d51a4d22c025655c1cbc511e633a91 /mail-mta/ssmtp/ssmtp-2.62-r7.ebuild
parentFix typo on src_configure. Bug #258405 (diff)
downloadhistorical-b0f6f970e30c397987c32242cb53cfb8f9a332a4.tar.gz
historical-b0f6f970e30c397987c32242cb53cfb8f9a332a4.tar.bz2
historical-b0f6f970e30c397987c32242cb53cfb8f9a332a4.zip
Cleanup, fix from Header when no gecos is available (#282907)
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'mail-mta/ssmtp/ssmtp-2.62-r7.ebuild')
-rw-r--r--mail-mta/ssmtp/ssmtp-2.62-r7.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/mail-mta/ssmtp/ssmtp-2.62-r7.ebuild b/mail-mta/ssmtp/ssmtp-2.62-r7.ebuild
new file mode 100644
index 000000000000..1e1fca7ed79c
--- /dev/null
+++ b/mail-mta/ssmtp/ssmtp-2.62-r7.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.62-r7.ebuild,v 1.1 2009/10/17 17:37:59 dertobi123 Exp $
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
+HOMEPAGE="ftp://ftp.debian.org/debian/pool/main/s/ssmtp/"
+SRC_URI="mirror://debian/pool/main/s/ssmtp/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl ipv6 md5sum maxsysuid"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ net-mail/mailbase
+ !net-mail/mailwrapper
+ !virtual/mta"
+PROVIDE="virtual/mta"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ enewgroup ssmtp
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Allow to specify the last used system user id, bug #231866
+ if use maxsysuid; then
+ epatch "${FILESDIR}"/${P}-maxsysuid.patch
+ epatch "${FILESDIR}"/${P}-maxsysuid-conf.patch
+ fi
+
+ #
+ epatch "${FILESDIR}/${P}-from_format_fix.patch"
+
+ # CVE-2008-3962
+ epatch "${FILESDIR}/CVE-2008-3962-r2.patch"
+
+ # Fix AuthPass parsing (bug #238724)
+ epatch "${FILESDIR}/${P}-authpass.patch"
+
+ epatch "${FILESDIR}/${P}-strndup.patch"
+ eautoreconf
+
+ # Respect LDFLAGS (bug #152197)
+ sed -i -e 's:$(CC) -o:$(CC) @LDFLAGS@ -o:' Makefile.in
+}
+
+src_compile() {
+ tc-export CC LD
+
+ econf \
+ --sysconfdir=/etc/ssmtp \
+ $(use_enable ssl) \
+ $(use_enable ipv6 inet6) \
+ $(use_enable md5sum md5auth) \
+ || die
+ make clean || die
+ make etcdir=/etc || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosbin ssmtp || die
+ fperms 755 /usr/sbin/ssmtp
+
+ doman ssmtp.8 ssmtp.conf.5
+ dodoc INSTALL README TLS CHANGELOG_OLD
+ newdoc ssmtp.lsm DESC
+
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases
+
+ local conffile="${D}etc/ssmtp/ssmtp.conf"
+
+ # Sorry about the weird indentation, I couldn't figure out a cleverer way
+ # to do this without having horribly >80 char lines.
+ sed -i -e "s:^hostname=:\n# Gentoo bug #47562\\
+# Commenting the following line will force ssmtp to figure\\
+# out the hostname itself.\n\\
+# hostname=:" \
+ "${conffile}" || die "sed failed"
+
+ # Comment rewriteDomain (bug #243364)
+ sed -i -e "s:^rewriteDomain=:#rewriteDomain=:" ${conffile}
+
+ # Set restrictive perms on ssmtp.conf as per #187841, #239197
+ # Protect the ssmtp configfile from being readable by regular users as it
+ # may contain login/password data to auth against a the mailhub used.
+ fowners root:ssmtp /etc/ssmtp/ssmtp.conf
+ fperms 640 /etc/ssmtp/ssmtp.conf
+
+ fowners root:ssmtp /usr/sbin/ssmtp
+ fperms 2711 /usr/sbin/ssmtp
+
+ dosym /usr/sbin/ssmtp /usr/lib/sendmail
+ dosym /usr/sbin/ssmtp /usr/bin/sendmail
+ dosym /usr/sbin/ssmtp /usr/sbin/sendmail
+ dosym /usr/sbin/ssmtp /usr/bin/mailq
+ dosym /usr/sbin/ssmtp /usr/bin/newaliases
+}