summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-03-23 14:24:46 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-03-23 14:24:46 +0000
commitf8f07ed2c3c1eab6bde1824b41cef6958cb61e4e (patch)
tree685ceef912f2eff55d15970ac7c0d8e913ed0e6a /kde-misc
parentsed || die. Reported by Maurizio Camisaschi in bug 388225. (diff)
downloadhistorical-f8f07ed2c3c1eab6bde1824b41cef6958cb61e4e.tar.gz
historical-f8f07ed2c3c1eab6bde1824b41cef6958cb61e4e.tar.bz2
historical-f8f07ed2c3c1eab6bde1824b41cef6958cb61e4e.zip
version bump
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/entropy-kioslaves/ChangeLog8
-rw-r--r--kde-misc/entropy-kioslaves/entropy-kioslaves-1.0_rc90.ebuild48
-rw-r--r--kde-misc/magneto-kde/ChangeLog7
-rw-r--r--kde-misc/magneto-kde/magneto-kde-1.0_rc90.ebuild39
4 files changed, 100 insertions, 2 deletions
diff --git a/kde-misc/entropy-kioslaves/ChangeLog b/kde-misc/entropy-kioslaves/ChangeLog
index 4a216b4817d2..ad82e77954a6 100644
--- a/kde-misc/entropy-kioslaves/ChangeLog
+++ b/kde-misc/entropy-kioslaves/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/entropy-kioslaves
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/entropy-kioslaves/ChangeLog,v 1.17 2012/02/12 07:27:22 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/entropy-kioslaves/ChangeLog,v 1.18 2012/03/23 14:21:52 lxnay Exp $
+
+*entropy-kioslaves-1.0_rc90 (23 Mar 2012)
+
+ 23 Mar 2012; Fabio Erculiani <lxnay@gentoo.org>
+ +entropy-kioslaves-1.0_rc90.ebuild:
+ version bump
*entropy-kioslaves-1.0_rc87 (12 Feb 2012)
diff --git a/kde-misc/entropy-kioslaves/entropy-kioslaves-1.0_rc90.ebuild b/kde-misc/entropy-kioslaves/entropy-kioslaves-1.0_rc90.ebuild
new file mode 100644
index 000000000000..293e941ca1d5
--- /dev/null
+++ b/kde-misc/entropy-kioslaves/entropy-kioslaves-1.0_rc90.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/entropy-kioslaves/entropy-kioslaves-1.0_rc90.ebuild,v 1.1 2012/03/23 14:21:52 lxnay Exp $
+
+EAPI="3"
+KDE_MINIMAL="4.2"
+inherit eutils kde4-base
+
+DESCRIPTION="Entropy Package Manager KDE kioslaves support"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+RDEPEND=">=app-admin/sulfur-${PV}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ einfo "nothing to prepare"
+}
+
+src_configure() {
+ einfo "nothing to configure"
+}
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ dodir "/${KDEDIR}/share/kde4/services/"
+ insinto "/${KDEDIR}/share/kde4/services/"
+ doins "${S}/sulfur/misc/entropy.protocol"
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+}
+
+pkg_postrm() {
+ kde4-base_pkg_postrm
+}
diff --git a/kde-misc/magneto-kde/ChangeLog b/kde-misc/magneto-kde/ChangeLog
index d29f10957279..005d230862bc 100644
--- a/kde-misc/magneto-kde/ChangeLog
+++ b/kde-misc/magneto-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/magneto-kde
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.17 2012/02/12 07:29:48 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.18 2012/03/23 14:24:46 lxnay Exp $
+
+*magneto-kde-1.0_rc90 (23 Mar 2012)
+
+ 23 Mar 2012; Fabio Erculiani <lxnay@gentoo.org> +magneto-kde-1.0_rc90.ebuild:
+ version bump
*magneto-kde-1.0_rc87 (12 Feb 2012)
diff --git a/kde-misc/magneto-kde/magneto-kde-1.0_rc90.ebuild b/kde-misc/magneto-kde/magneto-kde-1.0_rc90.ebuild
new file mode 100644
index 000000000000..540540b08ca0
--- /dev/null
+++ b/kde-misc/magneto-kde/magneto-kde-1.0_rc90.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/magneto-kde-1.0_rc90.ebuild,v 1.1 2012/03/23 14:24:46 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet KDE frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ kde-base/pykde4
+ dev-python/PyQt4[dbus]"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-kde-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/kde"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/kde"
+}