summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBo Ørsted Andresen <zlin@gentoo.org>2008-01-27 15:25:21 +0000
committerBo Ørsted Andresen <zlin@gentoo.org>2008-01-27 15:25:21 +0000
commitece5449258b6416c645727b7a02af1b5c20b1290 (patch)
treea405ea534cf62083f4b7caa4a0b06646490d7b2f /kde-base/systemsettings/files
parentMarking libao-0.8.8 ppc64 for bug 207682 (diff)
downloadhistorical-ece5449258b6416c645727b7a02af1b5c20b1290.tar.gz
historical-ece5449258b6416c645727b7a02af1b5c20b1290.tar.bz2
historical-ece5449258b6416c645727b7a02af1b5c20b1290.zip
Fix compilation with USE=-opengl. For bug #206517. Fix a typo.
Package-Manager: portage-2.1.4
Diffstat (limited to 'kde-base/systemsettings/files')
-rw-r--r--kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch b/kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch
new file mode 100644
index 000000000000..f3e6a966b4ff
--- /dev/null
+++ b/kde-base/systemsettings/files/systemsettings-4.0.0-opengl.patch
@@ -0,0 +1,21 @@
+--- workspace/CMakeLists.txt (revision 767202)
++++ workspace/CMakeLists.txt (working copy)
+@@ -16,8 +16,6 @@
+ include (MacroLibrary)
+ include (KDE4Defaults)
+
+-macro_optional_find_package(OpenGL)
+-
+ include(ConfigureChecks.cmake)
+ configure_file(config-unix.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-unix.h )
+ configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h )
+--- workspace/kcontrol/screensaver/CMakeLists.txt
++++ workspace/kcontrol/screensaver/CMakeLists.txt
+@@ -1,5 +1,7 @@
+
++if(WITH_OpenGL)
+ check_library_exists(GL glXChooseVisual "" HAVE_GLXCHOOSEVISUAL)
++endif(WITH_OpenGL)
+ configure_file (config-screensaver.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-screensaver.h )
+
+ add_definitions (-DQT3_SUPPORT)