summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 00:54:39 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 00:54:39 +0000
commit693347678da3f49fb4612dd8e6b3fc31915fcd1c (patch)
tree6908c2585700ce9db99f8ffed322f40be598c99a /kde-base/phonon/phonon-4.0.4.ebuild
parentAdded KDE 4.0.4 version of parley. Thanks to Jorge Manuel B. S. Vicetto. (diff)
downloadhistorical-693347678da3f49fb4612dd8e6b3fc31915fcd1c.tar.gz
historical-693347678da3f49fb4612dd8e6b3fc31915fcd1c.tar.bz2
historical-693347678da3f49fb4612dd8e6b3fc31915fcd1c.zip
Added KDE 4.0.4 version of phonon. Thanks to Jorge Manuel B. S. Vicetto.
Package-Manager: portage-2.1.5
Diffstat (limited to 'kde-base/phonon/phonon-4.0.4.ebuild')
-rw-r--r--kde-base/phonon/phonon-4.0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/phonon/phonon-4.0.4.ebuild b/kde-base/phonon/phonon-4.0.4.ebuild
new file mode 100644
index 000000000000..e76282d400e3
--- /dev/null
+++ b/kde-base/phonon/phonon-4.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon/phonon-4.0.4.ebuild,v 1.1 2008/05/16 00:54:39 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-runtime
+KMMODULE=phonon
+inherit kde4-meta
+
+DESCRIPTION="KDE multimedia API"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug xcb"
+
+# There's currently only a xine backend for phonon available,
+# a gstreamer backend from TrollTech is in the works.
+DEPEND="
+ >=media-libs/xine-lib-1.1.9
+ xcb? ( x11-libs/libxcb )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use xcb; then
+ KDE4_BUILT_WITH_USE_CHECK="media-libs/xine-lib xcb"
+ fi
+
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with xcb XCB)
+ -DWITH_Xine=ON"
+
+ kde4-meta_src_compile
+}