summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
commitc720f79a21ec6fc47b92109987daca264d416bff (patch)
tree1b6bd65f854b288e82f20100a5ed85c008e3511e /kde-base/kttsd
parentadded ~amd64 (diff)
downloadhistorical-c720f79a21ec6fc47b92109987daca264d416bff.tar.gz
historical-c720f79a21ec6fc47b92109987daca264d416bff.tar.bz2
historical-c720f79a21ec6fc47b92109987daca264d416bff.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kttsd')
-rw-r--r--kde-base/kttsd/ChangeLog8
-rw-r--r--kde-base/kttsd/kttsd-4.0.3.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kttsd/ChangeLog b/kde-base/kttsd/ChangeLog
index a1bba54d36b6..3b74ae6d4ca5 100644
--- a/kde-base/kttsd/ChangeLog
+++ b/kde-base/kttsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kttsd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.90 2008/03/20 18:06:24 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.91 2008/04/03 21:34:46 philantrop Exp $
+
+*kttsd-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org> +kttsd-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kttsd-4.0.1.ebuild:
Old.
diff --git a/kde-base/kttsd/kttsd-4.0.3.ebuild b/kde-base/kttsd/kttsd-4.0.3.ebuild
new file mode 100644
index 000000000000..33bc2afd70dc
--- /dev/null
+++ b/kde-base/kttsd/kttsd-4.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-4.0.3.ebuild,v 1.1 2008/04/03 21:34:46 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdeaccessibility
+inherit kde4-meta
+
+DESCRIPTION="KDE text-to-speech subsystem"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug htmlhandbook ktts"
+
+COMMONDEPEND="ktts? ( alsa? ( >=media-libs/alsa-lib-1.0.14a ) )
+ >=kde-base/kcmshell-${PV}:${SLOT}
+ >=kde-base/knotify-${PV}:${SLOT}"
+DEPEND="${DEPEND} ${COMMONDEPEND}"
+RDEPEND="${RDEPEND} ${COMMONDEPEND}
+ ktts? ( app-accessibility/festival
+ app-accessibility/epos
+ app-accessibility/freetts )
+ app-accessibility/flite"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with alsa Alsa)
+ -DKDE4_KTTSD_PHONON=$(use alsa && echo ON || echo OFF)
+ -DKDE4_KTTSD_ALSA=$(use alsa && echo ON || echo OFF)
+ $(cmake-utils_use_with ktts Kttsmodule)"
+
+ kde4-meta_src_compile
+}