summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 18:25:49 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 18:25:49 +0000
commit4b56a9456112f0424b9de968daac0612d94c4386 (patch)
treee49905f06cc5d2008a7b44b78bdb1d963298c15d /kde-base/ksysguard
parentcleanout (diff)
downloadhistorical-4b56a9456112f0424b9de968daac0612d94c4386.tar.gz
historical-4b56a9456112f0424b9de968daac0612d94c4386.tar.bz2
historical-4b56a9456112f0424b9de968daac0612d94c4386.zip
Bump shiny new KDE 4.2.0
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.2.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index 370e38119c3b..77a730a96ad7 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.119 2009/01/14 15:38:54 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.120 2009/01/27 17:54:52 alexxy Exp $
+
+*ksysguard-4.2.0 (27 Jan 2009)
+
+ 27 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +ksysguard-4.2.0.ebuild:
+ Bump KDE-4.2.0
14 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> -ksysguard-4.1.2.ebuild,
-ksysguard-4.1.3.ebuild:
diff --git a/kde-base/ksysguard/ksysguard-4.2.0.ebuild b/kde-base/ksysguard/ksysguard-4.2.0.ebuild
new file mode 100644
index 000000000000..41c36d791402
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.2.0.ebuild,v 1.1 2009/01/27 17:54:52 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook lm_sensors"
+
+COMMONDEPEND="x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto"
+
+KMEXTRA="libs/ksysguard/"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with lm_sensors Sensors)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+# one out of two tests are broken. we just disable it. last tested on 4.1.0.
+ sed -e '/guitest/s/^/#DONOTTEST/' \
+ -i "${S}"/libs/ksysguard/tests/CMakeLists.txt
+
+ kde4-meta_src_test
+}