summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
committerAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
commit2949ed61ac331b42c84eab992aba8a8aa245811c (patch)
treeb8dc20afdeb0bb71b28d488e020b2d45cf5f25a6 /kde-base/ksplash
parentRemoving 0.1.0 ebuild (diff)
downloadhistorical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.gz
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.bz2
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.zip
Version bump KDE 4.3.3
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.3.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 30effc3d4978..e12fdfba6bba 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.38 2009/10/18 13:37:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.39 2009/11/02 21:43:02 wired Exp $
+
+*ksplash-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +ksplash-4.3.3.ebuild:
+ Version bump
18 Oct 2009; Markus Meier <maekke@gentoo.org> ksplash-4.3.1.ebuild:
x86 stable, bug #287697
diff --git a/kde-base/ksplash/ksplash-4.3.3.ebuild b/kde-base/ksplash/ksplash-4.3.3.ebuild
new file mode 100644
index 000000000000..05748ad59439
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.3.3.ebuild,v 1.1 2009/11/02 21:43:02 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}