summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
commit1eabee5424cb6b7feaebe52560d20f05e73e82c4 (patch)
treef0cdbe1f3e025f18ec8c0d13283c9223dba031ca /kde-base/kontact
parentAdd support for Prefix. bug #407193 (diff)
downloadhistorical-1eabee5424cb6b7feaebe52560d20f05e73e82c4.tar.gz
historical-1eabee5424cb6b7feaebe52560d20f05e73e82c4.tar.bz2
historical-1eabee5424cb6b7feaebe52560d20f05e73e82c4.zip
Version bump KDE SC 4.8.1
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kontact')
-rw-r--r--kde-base/kontact/ChangeLog7
-rw-r--r--kde-base/kontact/kontact-4.8.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/kontact/ChangeLog b/kde-base/kontact/ChangeLog
index 3b15ffd8890d..045855fdff4e 100644
--- a/kde-base/kontact/ChangeLog
+++ b/kde-base/kontact/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kontact
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.206 2012/02/18 15:49:28 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.207 2012/03/06 23:35:36 dilfridge Exp $
+
+*kontact-4.8.1 (06 Mar 2012)
+
+ 06 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> +kontact-4.8.1.ebuild:
+ Version bump KDE SC 4.8.1
18 Feb 2012; nixnut <nixnut@gentoo.org> kontact-4.7.4.ebuild:
ppc stable #396359
diff --git a/kde-base/kontact/kontact-4.8.1.ebuild b/kde-base/kontact/kontact-4.8.1.ebuild
new file mode 100644
index 000000000000..857be5c98b1f
--- /dev/null
+++ b/kde-base/kontact/kontact-4.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.8.1.ebuild,v 1.1 2012/03/06 23:35:36 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="kdepim-common-libs"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+KMEXTRACTONLY="
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ libkdepimdbusinterfaces/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}