summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
commit5a13ccd21de0abab5282365a5070ba7229e9b098 (patch)
tree0793ec455fa77a823da333d1bf4faf15ecd53b10 /kde-base/kinfocenter
parentFix variable test. Thx to salnx per forums for the fix. (diff)
downloadhistorical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.gz
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.bz2
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.zip
Version bump KDE 4.2.4
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kinfocenter')
-rw-r--r--kde-base/kinfocenter/ChangeLog8
-rw-r--r--kde-base/kinfocenter/kinfocenter-4.2.4.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/kinfocenter/ChangeLog b/kde-base/kinfocenter/ChangeLog
index e5c51a924b68..d48702f33323 100644
--- a/kde-base/kinfocenter/ChangeLog
+++ b/kde-base/kinfocenter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kinfocenter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/ChangeLog,v 1.26 2009/06/03 16:13:57 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/ChangeLog,v 1.27 2009/06/04 12:39:48 alexxy Exp $
+
+*kinfocenter-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org>
+ +kinfocenter-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org>
-kinfocenter-4.2.2.ebuild:
diff --git a/kde-base/kinfocenter/kinfocenter-4.2.4.ebuild b/kde-base/kinfocenter/kinfocenter-4.2.4.ebuild
new file mode 100644
index 000000000000..c3c54cb2f15e
--- /dev/null
+++ b/kde-base/kinfocenter/kinfocenter-4.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/kinfocenter-4.2.4.ebuild,v 1.1 2009/06/04 12:39:48 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Info Center"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook ieee1394"
+
+DEPEND="
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? ( virtual/glu virtual/opengl )
+"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils
+ sys-apps/usbutils
+"
+
+KMEXTRACTONLY="
+ cmake/modules/
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with ieee1394 RAW1394)
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}