summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
commit307c276a3b4c55dca98f0a87512c3cbb4ace9264 (patch)
treebe7fdf498714778819009f86b7aa2b771e52ebd1 /kde-base/kdeplasma-addons
parentMask KDE SC 4.5 due to missing deps on ppc ppc64 and x86-fbsd. bug #336158 (diff)
downloadhistorical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.tar.gz
historical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.tar.bz2
historical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.zip
[kde-base] Add KDE SC 4.5.4
Package-Manager: portage-2.2.0_alpha6_p10/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.5.4.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index 2253de5669d8..39d96c4e3de5 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.75 2010/11/03 17:07:18 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.76 2010/12/02 21:17:19 alexxy Exp $
+
+*kdeplasma-addons-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdeplasma-addons-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
*kdeplasma-addons-4.5.3 (03 Nov 2010)
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.5.4.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.5.4.ebuild
new file mode 100644
index 000000000000..f92097dac8e0
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.5.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.5.4.ebuild,v 1.1 2010/12/02 21:17:19 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeplasma-addons"
+WEBKIT_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines."
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug desktopglobe exif qalculate qwt rss scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ dev-libs/libattica
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'rss?')
+ x11-misc/shared-mime-info
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ rss? ( $(add_kdebase_dep kdepimlibs 'semantic-desktop') )
+ scim? ( app-i18n/scim )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+# kde-misc/plasmaboard: moved here in 4.3.65
+# kde-misc/qalculate-applet: since 4.4.0
+RDEPEND="${COMMON_DEPEND}
+ !kdeprefix? (
+ !kde-misc/plasmaboard
+ !kde-misc/qalculate-applet
+ )
+"
+
+# kdebase-data: some svg icons moved from data directly here.
+add_blocker kdebase-data '<4.2.88'
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.74-cmake.patch"
+)
+
+src_prepare() {
+ find "${S}" -name CMakeLists.txt | \
+ xargs sed -i \
+ -e 's/${KDE4WORKSPACE_PLASMACLOCK_LIBRARY}/plasmaclock/g' \
+ -e 's/${KDE4WORKSPACE_WEATHERION_LIBRARY}/weather_ion/g' \
+ -e 's/${KDE4WORKSPACE_TASKMANAGER_LIBRARY}/taskmanager/g' \
+ || die "Failed to patch CMake files"
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EKDEDIR}/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with rss KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}