summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-07-21 14:13:29 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-07-21 14:13:29 +0000
commita1e7b6e7480b1c58b97e4a93e4e7f488e9846ced (patch)
treea6f046e669209115b87da1b816088776e0b6f381 /kde-base/kdenetwork/kdenetwork-3.3.2-r2.ebuild
parentStable on ppc64 (diff)
downloadhistorical-a1e7b6e7480b1c58b97e4a93e4e7f488e9846ced.tar.gz
historical-a1e7b6e7480b1c58b97e4a93e4e7f488e9846ced.tar.bz2
historical-a1e7b6e7480b1c58b97e4a93e4e7f488e9846ced.zip
Fix vulnerabilities in libgadu (#99754).
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'kde-base/kdenetwork/kdenetwork-3.3.2-r2.ebuild')
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.3.2-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/kde-base/kdenetwork/kdenetwork-3.3.2-r2.ebuild b/kde-base/kdenetwork/kdenetwork-3.3.2-r2.ebuild
new file mode 100644
index 000000000000..11f97484a135
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.3.2-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.3.2-r2.ebuild,v 1.1 2005/07/21 14:13:29 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE network apps: kopete, kppp, kget..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE="slp samba wifi ssl"
+
+DEPEND="~kde-base/kdebase-${PV}
+ slp? ( net-libs/openslp )
+ samba? ( net-fs/samba )
+ ssl? ( app-crypt/qca-tls )
+ wifi? ( <=net-wireless/wireless-tools-28_pre6 )"
+
+SRC_URI="${SRC_URI}
+ mirror://kde/security_patches/post-3.3.2-kdenetwork-libgadu.patch"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix to make kopete connect to msn (kde bug 105929). Applied upstream.
+ epatch "${FILESDIR}/${P}-kopete-msn.patch"
+
+ # Fix bug #75907. Applied upstream.
+ epatch "${FILESDIR}/${P}-kwifimanager-configlocation.patch"
+
+ # Fix vulnerabilities in libgadu. See bug 99754.
+ epatch "${DISTDIR}/post-3.3.2-kdenetwork-libgadu.patch"
+}
+
+src_compile() {
+ myconf="$myconf $(use_enable slp)"
+ use wifi || DO_NOT_COMPILE="$DO_NOT_COMPILE wifi"
+ export DO_NOT_COMPILE
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ chmod +s ${D}/${KDEDIR}/bin/reslisa
+
+ # empty config file needed for lisa to work with default settings
+ touch ${D}/etc/lisarc
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${D}/etc/init.d/reslisa
+ chmod +x ${D}/etc/init.d/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+}