summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
commitc720f79a21ec6fc47b92109987daca264d416bff (patch)
tree1b6bd65f854b288e82f20100a5ed85c008e3511e /kde-base/kdemultimedia-kioslaves
parentadded ~amd64 (diff)
downloadhistorical-c720f79a21ec6fc47b92109987daca264d416bff.tar.gz
historical-c720f79a21ec6fc47b92109987daca264d416bff.tar.bz2
historical-c720f79a21ec6fc47b92109987daca264d416bff.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kdemultimedia-kioslaves')
-rw-r--r--kde-base/kdemultimedia-kioslaves/ChangeLog9
-rw-r--r--kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.0.3.ebuild49
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/kdemultimedia-kioslaves/ChangeLog b/kde-base/kdemultimedia-kioslaves/ChangeLog
index 9f8fe6f7c377..1c125278673a 100644
--- a/kde-base/kdemultimedia-kioslaves/ChangeLog
+++ b/kde-base/kdemultimedia-kioslaves/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdemultimedia-kioslaves
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.92 2008/03/20 16:48:20 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.93 2008/04/03 20:57:34 philantrop Exp $
+
+*kdemultimedia-kioslaves-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdemultimedia-kioslaves-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-kdemultimedia-kioslaves-4.0.1.ebuild:
diff --git a/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.0.3.ebuild b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.0.3.ebuild
new file mode 100644
index 000000000000..9265d4b2ab8a
--- /dev/null
+++ b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.0.3.ebuild,v 1.1 2008/04/03 20:57:34 philantrop Exp $
+
+EAPI="1"
+
+KMMODULE=kioslave
+KMNAME=kdemultimedia
+inherit kde4-meta
+
+DESCRIPTION="KDE kioslaves from the kdemultimedia package"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug encode flac vorbis"
+
+# Tests are broken. Last checked on 4.0.3.
+RESTRICT="test"
+
+DEPEND="${DEPEND}
+ >=kde-base/libkcddb-${PV}:${SLOT}
+ >=kde-base/libkcompactdisc-${PV}:${SLOT}
+ media-sound/cdparanoia
+ encode? ( flac? ( >=media-libs/flac-1.1.2 )
+ vorbis? ( media-libs/libvorbis ) )"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkcompactdisc/"
+KMCOMPILEONLY="libkcddb/"
+
+src_compile() {
+ if use encode; then
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with flac Flac)
+ $(cmake-utils_use_with vorbis OggVorbis)"
+ else
+ mycmakeargs="${mycmakeargs}
+ -DWITH_OggVorbis=OFF -DWITH_Flac=OFF"
+ fi
+
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ if use encode; then
+ echo
+ elog "In order to use the lame plugin to encode mp3 files you will need to"
+ elog "install media-sound/lame"
+ echo
+ fi
+}