summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-12 22:07:35 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-12 22:07:35 +0000
commit5115fd738f4c88f5d17516e97513443e5cf93bd9 (patch)
treebb6c590e8ead0402fc3cef06832546cfee5d3adb /kde-base/kdebindings
parentClosing bug # 4916. (diff)
downloadhistorical-5115fd738f4c88f5d17516e97513443e5cf93bd9.tar.gz
historical-5115fd738f4c88f5d17516e97513443e5cf93bd9.tar.bz2
historical-5115fd738f4c88f5d17516e97513443e5cf93bd9.zip
kde 3.1 alpha1 (masked)
Diffstat (limited to 'kde-base/kdebindings')
-rw-r--r--kde-base/kdebindings/files/digest-kdebindings-3.1_alpha11
-rw-r--r--kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/kdebindings/files/digest-kdebindings-3.1_alpha1 b/kde-base/kdebindings/files/digest-kdebindings-3.1_alpha1
new file mode 100644
index 000000000000..de4ac8f3102f
--- /dev/null
+++ b/kde-base/kdebindings/files/digest-kdebindings-3.1_alpha1
@@ -0,0 +1 @@
+MD5 a3f18d02c2a567fb8c17aadef7e1ee84 kdebindings-3.0.6.tar.bz2 6142681
diff --git a/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild b/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild
new file mode 100644
index 000000000000..00ab2520a2fd
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1_alpha1.ebuild,v 1.1 2002/07/12 22:07:34 danarmak Exp $
+
+# TODO: add gnustep, objc bindings
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Bindings"
+
+newdepend "~kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ ~kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+src_unpack()
+{
+ base_src_unpack
+
+ if [ -z "`use mozilla`" ]; then
+ # disable mozilla bindings/xpart
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+ chmod +x configure
+ fi
+}