summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-08-19 09:34:02 +0000
committerDan Armak <danarmak@gentoo.org>2002-08-19 09:34:02 +0000
commitb3daa856aa0f99bf90d28f2c5c8d07e820fd8d74 (patch)
treeccae8e2bba4d33671197872ebd40589f7e2aefd4 /kde-base/kdebase
parentremove another no-longer-in-use patchfile (diff)
downloadhistorical-b3daa856aa0f99bf90d28f2c5c8d07e820fd8d74.tar.gz
historical-b3daa856aa0f99bf90d28f2c5c8d07e820fd8d74.tar.bz2
historical-b3daa856aa0f99bf90d28f2c5c8d07e820fd8d74.zip
KDE 3.0.3. Enjoy! sparc, ppc guys: please keyword-ify for your platforms
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.0.31
-rw-r--r--kde-base/kdebase/files/startkde-3.0.3-gentoo.diff41
-rw-r--r--kde-base/kdebase/kdebase-3.0.3.ebuild99
3 files changed, 141 insertions, 0 deletions
diff --git a/kde-base/kdebase/files/digest-kdebase-3.0.3 b/kde-base/kdebase/files/digest-kdebase-3.0.3
new file mode 100644
index 000000000000..58eb734f81d7
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.0.3
@@ -0,0 +1 @@
+MD5 a1c6cb06468608318c5e59e362773360 kdebase-3.0.3.tar.bz2 13112153
diff --git a/kde-base/kdebase/files/startkde-3.0.3-gentoo.diff b/kde-base/kdebase/files/startkde-3.0.3-gentoo.diff
new file mode 100644
index 000000000000..0166cdd888f8
--- /dev/null
+++ b/kde-base/kdebase/files/startkde-3.0.3-gentoo.diff
@@ -0,0 +1,41 @@
+--- startkde.orig Wed Aug 7 19:55:10 2002
++++ startkde Mon Aug 19 11:48:35 2002
+@@ -1,8 +1,21 @@
+-#!/bin/sh
++#!/bin/sh --login
+ #
+-# DEFAULT KDE STARTUP SCRIPT ( KDE-3.0.3 )
++# GENTOO CUSTOMIZED KDE STARTUP SCRIPT ( KDE-3.0.3 )
+ #
+
++# Gentoo part:
++export PATH="_KDEDIR_/bin:${PATH}"
++export KDEDIR="_KDEDIR_"
++export KDEDIRS="_KDEDIR_:/usr" # do NOT include env.d's $KDEDIRS
++
++cd ~
++[ -d .kde ] && mv .kde .kde.backup
++[ -e .kde3 ] || mkdir .kde3
++ln -sf .kde3 .kde
++export KDEHOME="${HOME}/.kde3"
++
++# Gentoo part ends
++
+ # Boot sequence:
+ #
+ # kdeinit is used to fork off processes which improves memory usage
+@@ -25,12 +38,12 @@
+ # especially necessary on slow machines, where starting KDE takes one or two
+ # minutes until anything appears on the screen.
+ #
+-# Set the background to plain grey.
++# Set the background to cyan (Gentoo version change).
+ # The standard X background is nasty, causing moire effects and exploding
+ # people's heads. We use colours from the standard KDE palette for those with
+ # palettised displays.
+
+-test "$XDM_MANAGED" || bkg="-solid #C0C0C0"
++test "$XDM_MANAGED" || bkg="-solid #5477A0"
+ xsetroot -cursor_name left_ptr $bkg
+
+ # The user's personal KDE directory is usually ~/.kde, but this setting
diff --git a/kde-base/kdebase/kdebase-3.0.3.ebuild b/kde-base/kdebase/kdebase-3.0.3.ebuild
new file mode 100644
index 000000000000..c14feb0da96a
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.0.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.0.3.ebuild,v 1.1 2002/08/19 09:34:02 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="x86"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ encode? ( >=media-sound/lame-3.89b )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ opengl? ( virtual/opengl )
+ samba? ( net-fs/samba )"
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+myconf="$myconf --with-dpms --with-cdparanoia"
+
+use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+use encode && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+# fix for verwilst's gcc 3.1 & antialiasing problem
+PATCHES="$FILESDIR/${P}-fonts.cpp.patch"
+
+src_compile() {
+
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ # old scheme - compatibility
+ exeinto /usr/X11R6/bin/wm
+ doexe kde-${PV}
+ # new scheme - for now >=xfree-4.2-r3 only
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e 's:SessionTypes=:SessionTypes=kde-3.0,kde-2.2.2,:' kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ mkdir -p ${D}/usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+}