summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:23:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:23:25 +0000
commit101e02e10949a17f49a3729a8808738032cb5727 (patch)
tree81617ce50ecfcc5aadd62ad970a466983ccde924 /kde-base/kde-l10n
parent[kde-base/svgpart] Version bump to KDE SC 4.4.0 (diff)
downloadhistorical-101e02e10949a17f49a3729a8808738032cb5727.tar.gz
historical-101e02e10949a17f49a3729a8808738032cb5727.tar.bz2
historical-101e02e10949a17f49a3729a8808738032cb5727.zip
[kde-base/kde-l10n] Version bump to KDE SC 4.4.0
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog7
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.4.0.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 60b2ff6e0f97..d94452df822a 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.53 2010/01/25 15:19:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.54 2010/02/09 00:23:24 alexxy Exp $
+
+*kde-l10n-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +kde-l10n-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*kde-l10n-4.3.5 (25 Jan 2010)
diff --git a/kde-base/kde-l10n/kde-l10n-4.4.0.ebuild b/kde-base/kde-l10n/kde-l10n-4.4.0.ebuild
new file mode 100644
index 000000000000..1915f29405a4
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.4.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.4.0.ebuild,v 1.1 2010/02/09 00:23:24 alexxy Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+MY_LANGS="ar bg ca ca@valencia cs csb da de el en_GB eo es et eu
+ fi fr fy ga gl gu he hi hr hu id is it ja kk km kn ko lt lv
+ mai mk ml nb nds nl nn pa pl pt pt_BR ro ru si sk sl sr sv tg
+ tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook docs)"
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}