summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
commit5927f5c54422bdd7e485d04e5a5f7d18663ee66f (patch)
tree23ce069db9e32e9974c6b94cfa73af651ada1e7f /kde-base/dolphin
parentMask >ghc-7 on Tiger and Leopard (diff)
downloadhistorical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.gz
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.bz2
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.zip
Version bump KDE SC 4.8.3
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.8.3.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index c37e28a9f401..54ad93c559fd 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.132 2012/04/18 21:54:49 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.133 2012/05/03 20:07:58 johu Exp $
+
+*dolphin-4.8.3 (03 May 2012)
+
+ 03 May 2012; Johannes Huber <johu@gentoo.org> +dolphin-4.8.3.ebuild:
+ Version bump KDE SC 4.8.3
18 Apr 2012; Markus Meier <maekke@gentoo.org> dolphin-4.8.1.ebuild:
x86 stable, bug #409403
diff --git a/kde-base/dolphin/dolphin-4.8.3.ebuild b/kde-base/dolphin/dolphin-4.8.3.ebuild
new file mode 100644
index 000000000000..b422504ba438
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.8.3.ebuild,v 1.1 2012/05/03 20:07:58 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( dev-libs/shared-desktop-ontologies )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ echo
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ echo
+}