summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit3cd76e5fe7d7273a171c99e9b2eef417bf1a8981 (patch)
tree61f043a2442a33d46c1c7793f2dc73363dc27b05 /kde-base/dolphin
parentUse github from thirdpartymirrors. (diff)
downloadhistorical-3cd76e5fe7d7273a171c99e9b2eef417bf1a8981.tar.gz
historical-3cd76e5fe7d7273a171c99e9b2eef417bf1a8981.tar.bz2
historical-3cd76e5fe7d7273a171c99e9b2eef417bf1a8981.zip
Version bump KDE SC 4.8.0
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.8.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 2011f7269e75..ab5b72aad1b6 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.122 2012/01/17 22:00:19 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.123 2012/01/25 18:17:10 johu Exp $
+
+*dolphin-4.8.0 (25 Jan 2012)
+
+ 25 Jan 2012; Johannes Huber <johu@gentoo.org> +dolphin-4.8.0.ebuild:
+ Version bump KDE SC 4.8.0
17 Jan 2012; Johannes Huber <johu@gentoo.org> dolphin-4.7.4.ebuild:
Add elog for .exe file preview, fixes bug #398697.
diff --git a/kde-base/dolphin/dolphin-4.8.0.ebuild b/kde-base/dolphin/dolphin-4.8.0.ebuild
new file mode 100644
index 000000000000..39f5c8a94778
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.8.0.ebuild,v 1.1 2012/01/25 18:17:10 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( dev-libs/shared-desktop-ontologies )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ echo
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ echo
+}