summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
commit75f228d8cf8a4fb6ddf12ece4c814b78edb95850 (patch)
tree2a0735defeb822e6f238e00f6c5e3fee524d661a /kde-base/ark/ark-4.6.4.ebuild
parentSort test dep. Remove useless dies. (diff)
downloadhistorical-75f228d8cf8a4fb6ddf12ece4c814b78edb95850.tar.gz
historical-75f228d8cf8a4fb6ddf12ece4c814b78edb95850.tar.bz2
historical-75f228d8cf8a4fb6ddf12ece4c814b78edb95850.zip
Version bump
Package-Manager: portage-2.1.10/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ark/ark-4.6.4.ebuild')
-rw-r--r--kde-base/ark/ark-4.6.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-base/ark/ark-4.6.4.ebuild b/kde-base/ark/ark-4.6.4.ebuild
new file mode 100644
index 000000000000..551880c6e2af
--- /dev/null
+++ b/kde-base/ark/ark-4.6.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.6.4.ebuild,v 1.1 2011/06/10 17:59:54 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}