summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-09-24 01:06:30 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-09-24 01:06:30 +0000
commitc8ff9abf6b0afe0cd8f59bc305ad6208be409d48 (patch)
treeed274989a2fdabf3d963bdc9673d02768e41eddd /gnustep-libs/renaissance/renaissance-0.8.0.ebuild
parentdont touch ld.so.conf #64829 (diff)
downloadhistorical-c8ff9abf6b0afe0cd8f59bc305ad6208be409d48.tar.gz
historical-c8ff9abf6b0afe0cd8f59bc305ad6208be409d48.tar.bz2
historical-c8ff9abf6b0afe0cd8f59bc305ad6208be409d48.zip
Major commit of many files relating to updated GNUstep ebuidlds
Diffstat (limited to 'gnustep-libs/renaissance/renaissance-0.8.0.ebuild')
-rw-r--r--gnustep-libs/renaissance/renaissance-0.8.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnustep-libs/renaissance/renaissance-0.8.0.ebuild b/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
new file mode 100644
index 000000000000..713aed2d7b6e
--- /dev/null
+++ b/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.8.0.ebuild,v 1.1 2004/09/24 01:03:01 fafhrd Exp $
+
+inherit gnustep
+
+S=${WORKDIR}/${P/r/R}
+
+DESCRIPTION="GNUstep Renaissance allows you to describe your user interfaces in simple and intuitive XML files."
+HOMEPAGE="http://www.gnustep.it/Renaissance/index.html"
+SRC_URI="http://www.gnustep.it/Renaissance/Download/${P/r/R}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+IUSE="${IUSE} doc"
+DEPEND="${GS_DEPEND}"
+RDEPEND="${GS_RDEPEND}"
+
+src_install() {
+ cd ${S}
+ egnustep_env
+ egnustep_install || die
+ if [ `use doc` ]; then
+ egnustep_env
+ cd Documentation
+ egnustep_make
+ egnustep_install
+ mkdir -p ${TMP}/tmpdocs
+ mv ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/* ${TMP}/tmpdocs
+ mkdir -p ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
+ mv ${TMP}/tmpdocs/* ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
+ cd ..
+ fi
+ egnustep_package_config
+}