summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 03:57:34 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 03:57:34 +0000
commit6486d5eb6821f11206ad4b65c8544342616bffb3 (patch)
tree9264b95e72d17215d556d612e27db4f10e4ad5fc /gnustep-apps/addresses/addresses-0.4.6-r1.ebuild
parentKeyworded ppc for GNOME 2.8 (diff)
downloadhistorical-6486d5eb6821f11206ad4b65c8544342616bffb3.tar.gz
historical-6486d5eb6821f11206ad4b65c8544342616bffb3.tar.bz2
historical-6486d5eb6821f11206ad4b65c8544342616bffb3.zip
Mass Update: gnustep.eclass revamped to allow configurable root install; gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions bumped where files would change); some KEYWORDS were accidentally dropped between version bumps of packages -- this has been resolved; windowmaker correctly supports gnustep now; gnustep-funcs.eclass added -- used where info on an installed gnustep-env is needed rather than making a full GNUstep application
Diffstat (limited to 'gnustep-apps/addresses/addresses-0.4.6-r1.ebuild')
-rw-r--r--gnustep-apps/addresses/addresses-0.4.6-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnustep-apps/addresses/addresses-0.4.6-r1.ebuild b/gnustep-apps/addresses/addresses-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..e3fd829923e5
--- /dev/null
+++ b/gnustep-apps/addresses/addresses-0.4.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/addresses/addresses-0.4.6-r1.ebuild,v 1.1 2004/11/12 03:49:45 fafhrd Exp $
+
+inherit gnustep eutils
+
+S=${WORKDIR}/${P/a/A}
+
+DESCRIPTION="Addresses is a Apple Addressbook work alike (standalone and for GNUMail)"
+HOMEPAGE="http://giesler.biz/bjoern/en/sw_addr.html"
+#SRC_URI="mirror://gentoo/${P/a/A}.tar.gz"
+#SRC_URI="http://dev.gentoo.org/~fafhrd/gnustep/apps/${P/a/A}.tar.gz"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/contrib/${P/a/A}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="${IUSE}"
+DEPEND="${GS_DEPEND}"
+RDEPEND="${GS_RDEPEND}"
+
+egnustep_install_domain "Local"
+
+src_unpack() {
+ egnustep_env
+ unpack ${A}
+ cd ${S}
+ if [ -z "${GNUSTEP_FLATTENED}" ]; then
+ epatch ${FILESDIR}/nonflattened.patch
+ fi
+ epatch ${FILESDIR}/address-user-root.patch
+}
+