summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-18 21:17:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-18 21:17:32 +0000
commitd0ddb20d7f3f8ad3615eed7d1c092e3c3cbd0be7 (patch)
tree0682928fc8ec85e59ace8cf965b58946517965a1 /gnome-extra
parentRespect LDFLAGS (bug #336155, and do not duplicate in the emake call what the... (diff)
downloadhistorical-d0ddb20d7f3f8ad3615eed7d1c092e3c3cbd0be7.tar.gz
historical-d0ddb20d7f3f8ad3615eed7d1c092e3c3cbd0be7.tar.bz2
historical-d0ddb20d7f3f8ad3615eed7d1c092e3c3cbd0be7.zip
Initial commit, replacement of music-applet, bug #299151.
Package-Manager: portage-2.2_rc78/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/panflute/ChangeLog10
-rw-r--r--gnome-extra/panflute/Manifest14
-rw-r--r--gnome-extra/panflute/metadata.xml9
-rw-r--r--gnome-extra/panflute/panflute-0.6.2.ebuild60
4 files changed, 93 insertions, 0 deletions
diff --git a/gnome-extra/panflute/ChangeLog b/gnome-extra/panflute/ChangeLog
new file mode 100644
index 000000000000..94aecc0a76c4
--- /dev/null
+++ b/gnome-extra/panflute/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnome-extra/panflute
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/ChangeLog,v 1.1 2010/09/18 21:17:32 eva Exp $
+
+*panflute-0.6.2 (18 Sep 2010)
+
+ 18 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +panflute-0.6.2.ebuild, +metadata.xml:
+ Initial commit, replacement of music-applet, bug #299151.
+
diff --git a/gnome-extra/panflute/Manifest b/gnome-extra/panflute/Manifest
new file mode 100644
index 000000000000..91c124ce9895
--- /dev/null
+++ b/gnome-extra/panflute/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST panflute-0.6.2.tar.gz 229268 RMD160 6b068d6abe3880d89f5c3471a6fc7aafcd09b453 SHA1 ca550405a5d2450260b764a576d60cf08328b716 SHA256 b38869e27bb22f9c3ea3d41f7c9cb3626fec49eac176410a5aa27bea9745617f
+EBUILD panflute-0.6.2.ebuild 1525 RMD160 6a995587a35fedab0e628e31aaa374835c747118 SHA1 e7c5d4ee313c041403fa5e82b05f8f7c580312cb SHA256 67291eb5922d7b2ebdeca237780370a8e8f6edfb7698dd7cd2e4a186cabd05d6
+MISC ChangeLog 397 RMD160 17611288b11d47d29869dc8de83d9df882f5c97c SHA1 f112e6b68172844820c25871e03f77b8be6eaf2c SHA256 f575301988eb48aada39fcd8813af189b2fa59db464c5983586609467af2f923
+MISC metadata.xml 239 RMD160 a0461891923f55c7034f2883109d613460489ef3 SHA1 aeca511f0e6c732886b06a50884c83de3c83df60 SHA256 cb07c9587f4637ec96982b5487883f7a2d3326cc2e55906e2c52ba13e0897980
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEUEARECAAYFAkyVLHEACgkQ1fmVwcYIWAZOmACgwMzjv8t9xBkfbzIw5ImaA40x
+eBsAl1D6OkUvOOpYXDQq85qZW9MU1ZY=
+=ZHHJ
+-----END PGP SIGNATURE-----
diff --git a/gnome-extra/panflute/metadata.xml b/gnome-extra/panflute/metadata.xml
new file mode 100644
index 000000000000..2438bbedd0a0
--- /dev/null
+++ b/gnome-extra/panflute/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>sound</herd>
+ <use>
+ <flag name="mpd">Enable MPD support</flag>
+ </use>
+</pkgmetadata>
diff --git a/gnome-extra/panflute/panflute-0.6.2.ebuild b/gnome-extra/panflute/panflute-0.6.2.ebuild
new file mode 100644
index 000000000000..872553f5fc49
--- /dev/null
+++ b/gnome-extra/panflute/panflute-0.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/panflute-0.6.2.ebuild,v 1.1 2010/09/18 21:17:32 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 python eutils versionator
+
+MY_MAJORV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="GNOME applet to control various music players"
+HOMEPAGE="http://launchpad.net/panflute"
+SRC_URI="http://launchpad.net/${PN}/${MY_MAJORV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome libnotify mpd"
+
+# This ebuild is far from perfect, it does a lot of automagic detection
+RDEPEND="
+ >=dev-python/dbus-python-0.80
+ >=dev-libs/dbus-glib-0.71
+ dev-python/pygobject
+ gnome? (
+ >=x11-libs/pango-1.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-panel-2
+ >=dev-python/gconf-python-2.14
+ >=dev-python/gnome-keyring-python-2.14
+ >=dev-python/gnome-applets-python-2.14
+ >=dev-python/pygtk-2.16 )
+ libnotify? ( dev-python/notify-python )
+ mpd? ( >=dev-python/python-mpd-0.2.1 )
+ !gnome-extra/music-applet
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/panflute
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/panflute
+}