summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-10-17 19:36:26 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-10-17 19:36:26 +0000
commitcfe993153c15c99d46da48abc23cfff35178ffb3 (patch)
tree9881245ead819633c25177c099d8705bd3d095b8 /gnome-extra
parentadded ~mips after testing thanks to kumba (diff)
downloadhistorical-cfe993153c15c99d46da48abc23cfff35178ffb3.tar.gz
historical-cfe993153c15c99d46da48abc23cfff35178ffb3.tar.bz2
historical-cfe993153c15c99d46da48abc23cfff35178ffb3.zip
added amd64 specific patch (#48948)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-games/ChangeLog6
-rw-r--r--gnome-extra/gnome-games/files/gnome-games-2.6.2-amd64.patch52
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.6.2.ebuild8
3 files changed, 64 insertions, 2 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index 9aea517ca7e9..cffd65591831 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/gnome-games
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.78 2004/10/11 23:14:33 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.79 2004/10/17 19:36:26 liquidx Exp $
+
+ 17 Oct 2004; Alastair Tse <liquidx@gentoo.org>
+ +files/gnome-games-2.6.2-amd64.patch, gnome-games-2.6.2.ebuild:
+ added amd64 specific patch (#48948)
*gnome-games-2.8.1 (12 Oct 2004)
diff --git a/gnome-extra/gnome-games/files/gnome-games-2.6.2-amd64.patch b/gnome-extra/gnome-games/files/gnome-games-2.6.2-amd64.patch
new file mode 100644
index 000000000000..900afe561538
--- /dev/null
+++ b/gnome-extra/gnome-games/files/gnome-games-2.6.2-amd64.patch
@@ -0,0 +1,52 @@
+diff -ru gnome-games-2.6.2/gnometris/blockops.cpp /tmp/gnome-games-2.6.2/gnometris/blockops.cpp
+--- gnome-games-2.6.2/gnometris/blockops.cpp 2003-05-31 20:01:34.000000000 -0700
++++ /tmp/gnome-games-2.6.2/gnometris/blockops.cpp 2004-08-14 03:14:13.863616496 -0700
+@@ -33,7 +33,7 @@
+ "y", (double) y * BLOCK_SIZE,
+ "width", (double) BLOCK_SIZE,
+ "height", (double) BLOCK_SIZE,
+- 0);
++ NULL);
+
+ return it;
+ }
+diff -ru gnome-games-2.6.2/gnometris/field.cpp /tmp/gnome-games-2.6.2/gnometris/field.cpp
+--- gnome-games-2.6.2/gnometris/field.cpp 2002-05-04 09:43:54.000000000 -0700
++++ /tmp/gnome-games-2.6.2/gnometris/field.cpp 2004-08-14 03:13:43.052300528 -0700
+@@ -56,7 +56,7 @@
+ "y", (double) 0,
+ "width", (double) COLUMNS * BLOCK_SIZE,
+ "height", (double) LINES * BLOCK_SIZE,
+- 0);
++ NULL);
+ else
+ bg = gnome_canvas_item_new(
+ gnome_canvas_root(GNOME_CANVAS(w)),
+@@ -68,5 +68,5 @@
+ "fill_color", "black",
+ "outline_color", "black",
+ "width_units", 1.0,
+- 0);
++ NULL);
+ }
+diff -ru gnome-games-2.6.2/gnometris/tetris.cpp /tmp/gnome-games-2.6.2/gnometris/tetris.cpp
+--- gnome-games-2.6.2/gnometris/tetris.cpp 2004-02-23 03:09:11.000000000 -0700
++++ /tmp/gnome-games-2.6.2/gnometris/tetris.cpp 2004-08-14 03:14:01.866440344 -0700
+@@ -202,7 +202,7 @@
+ "y", LINES*BLOCK_SIZE/2.0,
+ "text", _("Paused"),
+ "size_points", 36.0,
+- 0
++ NULL
+ );
+
+ /* Since gnome_canvas doesn't support setting the size of text in
+@@ -230,7 +230,7 @@
+ "y", LINES*BLOCK_SIZE/2.0,
+ "text", _("Game Over"),
+ "size_points", 36.0,
+- 0
++ NULL
+ );
+
+ gnome_canvas_item_get_bounds (gameoverMessage, &x1, &y1, &x2, &y2);
diff --git a/gnome-extra/gnome-games/gnome-games-2.6.2.ebuild b/gnome-extra/gnome-games/gnome-games-2.6.2.ebuild
index d46d4ef10f61..e63d502f4ccd 100644
--- a/gnome-extra/gnome-games/gnome-games-2.6.2.ebuild
+++ b/gnome-extra/gnome-games/gnome-games-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.6.2.ebuild,v 1.7 2004/10/01 15:12:57 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.6.2.ebuild,v 1.8 2004/10/17 19:36:26 liquidx Exp $
inherit gnome2 eutils
@@ -27,6 +27,12 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
DOCS="AUTHORS ChangeLog HACKING INSTALL MAINTAINERS NEWS README TODO"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-amd64.patch
+}
+
src_install() {
gnome2_src_install