summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-03-17 20:30:27 +0000
committerHans de Graaff <graaff@gentoo.org>2009-03-17 20:30:27 +0000
commitcfda1e66c1b9dff0bd34a12fdb3cb61211f768e8 (patch)
tree3bbf5da6bded207d4e08f57455776bd404520665 /gnome-extra
parentkeyworded ~arch for sparc (diff)
downloadhistorical-cfda1e66c1b9dff0bd34a12fdb3cb61211f768e8.tar.gz
historical-cfda1e66c1b9dff0bd34a12fdb3cb61211f768e8.tar.bz2
historical-cfda1e66c1b9dff0bd34a12fdb3cb61211f768e8.zip
Version bump
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-do-plugins/ChangeLog8
-rw-r--r--gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.1.3.ebuild54
-rw-r--r--gnome-extra/gnome-do/ChangeLog8
-rw-r--r--gnome-extra/gnome-do/gnome-do-0.8.1.3.ebuild55
4 files changed, 123 insertions, 2 deletions
diff --git a/gnome-extra/gnome-do-plugins/ChangeLog b/gnome-extra/gnome-do-plugins/ChangeLog
index 9347874ea810..dc1e8bb4cca4 100644
--- a/gnome-extra/gnome-do-plugins/ChangeLog
+++ b/gnome-extra/gnome-do-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gnome-do-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.8 2009/03/17 19:33:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.9 2009/03/17 20:30:27 graaff Exp $
+
+*gnome-do-plugins-0.8.1.3 (17 Mar 2009)
+
+ 17 Mar 2009; Hans de Graaff <graaff@gentoo.org>
+ +gnome-do-plugins-0.8.1.3.ebuild:
+ Version bump to go with the gnome-do 0.8.1.3 release.
17 Mar 2009; Hans de Graaff <graaff@gentoo.org>
-gnome-do-plugins-0.6.0.1.ebuild:
diff --git a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.1.3.ebuild b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.1.3.ebuild
new file mode 100644
index 000000000000..523ad41982b7
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.1.3.ebuild,v 1.1 2009/03/17 20:30:27 graaff Exp $
+
+inherit eutils autotools gnome2 mono versionator
+
+MY_PN="do-plugins"
+PVC=$(get_version_component_range 1-3)
+
+DESCRIPTION="Plugins to put the Do in Gnome Do"
+HOMEPAGE="http://do.davebsd.com/"
+SRC_URI="https://launchpad.net/${MY_PN}/0.8/${PVC}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="banshee evo"
+
+RDEPEND=">=gnome-extra/gnome-do-${PV}
+ dev-dotnet/wnck-sharp
+ banshee? ( >=media-sound/banshee-1.4.2 )
+ evo? ( dev-dotnet/evolution-sharp )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/monodevelop"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -r -e "/(FLICKR|Flickr)/d" configure.ac Makefile.am
+ use banshee || sed -i -r -e "/(BANSHEE|Banshee)/d" configure.ac Makefile.am
+ use evo || sed -i -r -e "/(EVOLUTION|Evolution)/d" configure.ac Makefile.am
+ eautoreconf
+}
+
+src_compile()
+{
+ econf --enable-debug=no --enable-release=yes || die "configure failed"
+ # The make system is unfortunately broken for parallel builds and
+ # upstream indicated on IRC that they have no intention to fix
+ # that.
+ emake -j1 || die "make failed"
+}
+
+pkg_postinst()
+{
+ ewarn "Plugin handling has changed since gnome-do 0.4."
+ ewarn "If you install the gnome-do-plugins package you will have local copies"
+ ewarn "of the plugins, but you still need to manually enable them in Preferences."
+ ewarn "Also note that plugins installed from upstream may not be compatible with"
+ ewarn "your system. When in doubt check the output from gnome-do itself".
+ ewarn "Old plugins may not be compatible either."
+ ewarn "Check ~/.local/share/gnome-do/ if you have problems with plugins."
+}
diff --git a/gnome-extra/gnome-do/ChangeLog b/gnome-extra/gnome-do/ChangeLog
index a32c0982de9f..d29ca1069e20 100644
--- a/gnome-extra/gnome-do/ChangeLog
+++ b/gnome-extra/gnome-do/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gnome-do
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/ChangeLog,v 1.13 2009/03/17 19:37:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/ChangeLog,v 1.14 2009/03/17 20:28:13 graaff Exp $
+
+*gnome-do-0.8.1.3 (17 Mar 2009)
+
+ 17 Mar 2009; Hans de Graaff <graaff@gentoo.org> +gnome-do-0.8.1.3.ebuild:
+ Version bump closing #262797, see this blog entry for the changes:
+ http://jassmith.wordpress.com/2009/03/13/gnome-do-081-released/
17 Mar 2009; Hans de Graaff <graaff@gentoo.org> -gnome-do-0.6.1.0.ebuild:
Remove intermediate version that had some issues due to the online plugin
diff --git a/gnome-extra/gnome-do/gnome-do-0.8.1.3.ebuild b/gnome-extra/gnome-do/gnome-do-0.8.1.3.ebuild
new file mode 100644
index 000000000000..fe06d863ae93
--- /dev/null
+++ b/gnome-extra/gnome-do/gnome-do-0.8.1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/gnome-do-0.8.1.3.ebuild,v 1.1 2009/03/17 20:28:13 graaff Exp $
+
+# TODO: GNOME Do defaults to a debug build; to disable, --enable-release must
+# be passed. However, when doing this the build fails; figure out why.
+
+EAPI=2
+
+inherit gnome2 mono versionator eutils
+
+PVC=$(get_version_component_range 1-3)
+
+DESCRIPTION="GNOME Do allows you to get things done quickly"
+HOMEPAGE="http://do.davebsd.com/"
+SRC_URI="https://launchpad.net/do/0.8/${PVC}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=dev-dotnet/gconf-sharp-2.24.0
+ >=dev-dotnet/gtk-sharp-2.12.6
+ >=dev-dotnet/glade-sharp-2.12.6
+ dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-glib-sharp
+ >=dev-dotnet/gnome-desktop-sharp-2.24.0
+ >=dev-dotnet/gnome-keyring-sharp-1.0.0
+ >=dev-dotnet/gnome-sharp-2.24.0
+ >=dev-dotnet/gnomevfs-sharp-2.24.0
+ >=dev-dotnet/wnck-sharp-2.24.0
+ >=dev-dotnet/art-sharp-2.24.0
+ >=dev-dotnet/rsvg-sharp-2.24.0
+ dev-dotnet/mono-addins
+ dev-dotnet/notify-sharp
+ !<gnome-extra/gnome-do-plugins-0.8"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ dev-util/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_configure() {
+ gnome2_src_configure
+}
+
+src_compile() {
+ default
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}