summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-03-07 12:29:51 +0000
committerPacho Ramos <pacho@gentoo.org>2015-03-07 12:29:51 +0000
commita9b09b36c8ebc210a9da8a35e1ed0df8938398fe (patch)
treee8bf1804c1f057e3b823bd43c549e4eb145008f8 /gnome-extra/libgsf/libgsf-1.14.32.ebuild
parentAdd a new game, drop old (diff)
downloadhistorical-a9b09b36c8ebc210a9da8a35e1ed0df8938398fe.tar.gz
historical-a9b09b36c8ebc210a9da8a35e1ed0df8938398fe.tar.bz2
historical-a9b09b36c8ebc210a9da8a35e1ed0df8938398fe.zip
Version bump
Package-Manager: portage-2.2.17/cvs/Linux x86_64 Manifest-Sign-Key: 0xA188FBD4
Diffstat (limited to 'gnome-extra/libgsf/libgsf-1.14.32.ebuild')
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.32.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/libgsf-1.14.32.ebuild b/gnome-extra/libgsf/libgsf-1.14.32.ebuild
new file mode 100644
index 000000000000..8f765258d3f2
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.32.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.32.ebuild,v 1.1 2015/03/07 12:29:50 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? ( x11-libs/gtk+:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}