summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-13 18:15:54 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-13 18:15:54 +0000
commit5c831df2afe505d20240f02ce8a436cef3675599 (patch)
treee02c4f756dc8e3d0c4410dcbe3716de4dfbc8243 /gnome-base
parentVersion bump; gcr library was split out into a separate package. (diff)
downloadhistorical-5c831df2afe505d20240f02ce8a436cef3675599.tar.gz
historical-5c831df2afe505d20240f02ce8a436cef3675599.tar.bz2
historical-5c831df2afe505d20240f02ce8a436cef3675599.zip
Version bump with assorted bugfixes.
Package-Manager: portage-2.2.0_alpha104/cvs/Linux x86_64
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnome-keyring/ChangeLog8
-rw-r--r--gnome-base/libgnome-keyring/libgnome-keyring-3.4.1.ebuild50
-rw-r--r--gnome-base/libgnome-keyring/metadata.xml4
3 files changed, 61 insertions, 1 deletions
diff --git a/gnome-base/libgnome-keyring/ChangeLog b/gnome-base/libgnome-keyring/ChangeLog
index 1bdd7d929681..8baf32822672 100644
--- a/gnome-base/libgnome-keyring/ChangeLog
+++ b/gnome-base/libgnome-keyring/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/libgnome-keyring
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/ChangeLog,v 1.35 2012/05/09 16:10:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/ChangeLog,v 1.36 2012/05/13 18:15:54 tetromino Exp $
+
+*libgnome-keyring-3.4.1 (13 May 2012)
+
+ 13 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libgnome-keyring-3.4.1.ebuild:
+ Version bump with assorted bugfixes.
09 May 2012; Alexis Ballier <aballier@gentoo.org>
libgnome-keyring-3.2.2.ebuild:
diff --git a/gnome-base/libgnome-keyring/libgnome-keyring-3.4.1.ebuild b/gnome-base/libgnome-keyring/libgnome-keyring-3.4.1.ebuild
new file mode 100644
index 000000000000..f8ee7df2f6a4
--- /dev/null
+++ b/gnome-base/libgnome-keyring/libgnome-keyring-3.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/libgnome-keyring-3.4.1.ebuild,v 1.1 2012/05/13 18:15:54 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 python
+
+DESCRIPTION="Compatibility library for accessing secrets"
+HOMEPAGE="http://live.gnome.org/GnomeKeyring"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE="debug doc +introspection test"
+
+RDEPEND=">=sys-apps/dbus-1.0
+ >=gnome-base/gnome-keyring-3.1.92
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ test? ( =dev-lang/python-2* )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+
+ if use test; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Remove silly CFLAGS
+ sed -e 's:CFLAGS="$CFLAGS -g:CFLAGS="$CFLAGS:' \
+ -e 's:CFLAGS="$CFLAGS -O0:CFLAGS="$CFLAGS:' \
+ -i configure.ac configure || die "sed failed"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ dbus-launch emake check || die "tests failed"
+}
diff --git a/gnome-base/libgnome-keyring/metadata.xml b/gnome-base/libgnome-keyring/metadata.xml
index da6fd63d0085..3147d749554f 100644
--- a/gnome-base/libgnome-keyring/metadata.xml
+++ b/gnome-base/libgnome-keyring/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
+ introspection</flag>
+</use>
</pkgmetadata>