summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-30 01:02:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-30 01:02:51 +0000
commit4af6508cbe14aabd5be5718263b1e5378be2a997 (patch)
tree76849b5bf325c5d6bf55003558c7d48d8c845619 /gnome-base
parentRemoved libglade from the dependency list, as it is not required. This sorts... (diff)
downloadhistorical-4af6508cbe14aabd5be5718263b1e5378be2a997.tar.gz
historical-4af6508cbe14aabd5be5718263b1e5378be2a997.tar.bz2
historical-4af6508cbe14aabd5be5718263b1e5378be2a997.zip
Circular dependencies involved with USE dependent bonobo support have been sorted out.
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libglade/ChangeLog10
-rw-r--r--gnome-base/libglade/files/digest-libglade-0.17-r41
-rw-r--r--gnome-base/libglade/libglade-0.17-r4.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/gnome-base/libglade/ChangeLog b/gnome-base/libglade/ChangeLog
index 1c0520f1a080..11d764c5253e 100644
--- a/gnome-base/libglade/ChangeLog
+++ b/gnome-base/libglade/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/libglade
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.2 2002/03/30 01:02:51 seemant Exp $
+
+*libglade-0.17-r4 (29 Mar 2002)
+
+ 29 Mar 2002; Seemant Kulleen <seemant@gentoo.org> libglade-0.17-r4.ebuild :
+
+ gnome is now an optional dependency, and USE dependent bonobo support
+ is now compilable, because the libglade dependency in gnome-print has been
+ sorted out. This means the end of circular dependencies, hopefully.
*libglade-0.17-r3 (1 Feb 2002)
diff --git a/gnome-base/libglade/files/digest-libglade-0.17-r4 b/gnome-base/libglade/files/digest-libglade-0.17-r4
new file mode 100644
index 000000000000..f084922d5464
--- /dev/null
+++ b/gnome-base/libglade/files/digest-libglade-0.17-r4
@@ -0,0 +1 @@
+MD5 38b2e2cfd813783fe157617813bfe3b3 libglade-0.17.tar.gz 418921
diff --git a/gnome-base/libglade/libglade-0.17-r4.ebuild b/gnome-base/libglade/libglade-0.17-r4.ebuild
new file mode 100644
index 000000000000..c3937d5cfc62
--- /dev/null
+++ b/gnome-base/libglade/libglade-0.17-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.17-r4.ebuild,v 1.1 2002/03/30 01:02:51 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libglade allows programmes to load their UIs from an XMLS description at tuntime."
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://freshmeat.net/redir/libglade/5651/url_homepage/"
+
+RDEPEND=">=dev-libs/libxml-1.8.15
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myopts
+
+# Bonobo support creates a circular depend // Hallski
+ use bonobo \
+ && myconf="${myconf} --enable-bonobo" \
+ || myconf="${myconf} --disable-bonobo --disable-bonobotest"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome --enable-gnomedb" \
+ || myconf="${myconf} --without-gnome --disable-gnomedb"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-gnomedb \
+ --disable-bonobo --disable-bonobotest \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc doc/*.txt
+}