summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-02-12 11:06:20 +0000
committerJoe McCann <joem@gentoo.org>2005-02-12 11:06:20 +0000
commit4af1436615e0ad2b55d7fc69d0f502dfedc76518 (patch)
tree5625a2d377fb2a75b11378678e336950cca35b41 /gnome-base/libglade/libglade-2.4.2.ebuild
parentadded ~amd64 to KEYWORDS. fixes #81496 (diff)
downloadhistorical-4af1436615e0ad2b55d7fc69d0f502dfedc76518.tar.gz
historical-4af1436615e0ad2b55d7fc69d0f502dfedc76518.tar.bz2
historical-4af1436615e0ad2b55d7fc69d0f502dfedc76518.zip
Bug fix release. Fixes toolbar breakage from previous release.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'gnome-base/libglade/libglade-2.4.2.ebuild')
-rw-r--r--gnome-base/libglade/libglade-2.4.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnome-base/libglade/libglade-2.4.2.ebuild b/gnome-base/libglade/libglade-2.4.2.ebuild
new file mode 100644
index 000000000000..1837e3ae1a59
--- /dev/null
+++ b/gnome-base/libglade/libglade-2.4.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.4.2.ebuild,v 1.1 2005/02/12 11:06:20 joem Exp $
+
+# FIXME : catalog stuff
+inherit gnome2 eutils
+
+DESCRIPTION="GLADE is a interface builder"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=x11-libs/gtk+-2.4
+ >=dev-libs/atk-1
+ >=dev-libs/libxml2-2.4.10
+ >=dev-lang/python-2.0-r7"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_compile() {
+
+ # patch to stop make install installing the xml catalog
+ # because we do it ourselves in postinst()
+ epatch ${FILESDIR}/Makefile.in.am-${PV}-xmlcatalog.patch
+
+ gnome2_src_compile
+
+}
+
+DOCS="ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+src_install() {
+
+ dodir /etc/xml
+ gnome2_src_install
+
+}
+
+
+pkg_postinst() {
+
+ echo ">>> Updating XML catalog"
+ /usr/bin/xmlcatalog --noout --add "system" \
+ "http://glade.gnome.org/glade-2.0.dtd" \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+ gnome2_pkg_postinst
+
+}
+
+pkg_postrm() {
+
+ echo ">>> removing entries from the XML catalog"
+ /usr/bin/xmlcatalog --noout --del \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+
+}