summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-12-07 16:28:59 +0000
committerMarinus Schraal <foser@gentoo.org>2003-12-07 16:28:59 +0000
commitdbd58ecd63a55338d1d716f17894c5adaca504b5 (patch)
treef3499d876bbcf2730e68ffd7662c063fd9354f34 /gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
parentadd patch to fix locale bug (diff)
downloadhistorical-dbd58ecd63a55338d1d716f17894c5adaca504b5.tar.gz
historical-dbd58ecd63a55338d1d716f17894c5adaca504b5.tar.bz2
historical-dbd58ecd63a55338d1d716f17894c5adaca504b5.zip
add patch to fix locale bug
Diffstat (limited to 'gnome-base/libghttp/libghttp-1.0.9-r4.ebuild')
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
new file mode 100644
index 000000000000..008f58175c00
--- /dev/null
+++ b/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild,v 1.1 2003/12/07 16:28:54 foser Exp $
+
+GNOME_TARBALL_SUFFIX="gz"
+inherit libtool gnome.org
+
+DESCRIPTION="GNOME http client library"
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fixes http locale related bug (#33386)
+ epatch ${FILESDIR}/${P}-fixlocale.patch
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ econf || die
+ emake || die
+
+}
+
+src_install() {
+ einstall || die
+
+ # headers needed for Intermezzo (bug 11501)
+ insinto /usr/include/ghttp-1.0/
+ doins http*.h
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dohtml doc/*.html
+}