summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-06-05 15:05:46 +0000
committerMarinus Schraal <foser@gentoo.org>2005-06-05 15:05:46 +0000
commitdc723d93615891ea8f247da9f81e71f9b40cf739 (patch)
treebbfbced0fa208ef229196881fc77fca6c2ea4d41 /gnome-base/gdm/gdm-2.6.0.9-r3.ebuild
parentmore old configs (diff)
downloadhistorical-dc723d93615891ea8f247da9f81e71f9b40cf739.tar.gz
historical-dc723d93615891ea8f247da9f81e71f9b40cf739.tar.bz2
historical-dc723d93615891ea8f247da9f81e71f9b40cf739.zip
fix ipv6 switch
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'gnome-base/gdm/gdm-2.6.0.9-r3.ebuild')
-rw-r--r--gnome-base/gdm/gdm-2.6.0.9-r3.ebuild139
1 files changed, 139 insertions, 0 deletions
diff --git a/gnome-base/gdm/gdm-2.6.0.9-r3.ebuild b/gnome-base/gdm/gdm-2.6.0.9-r3.ebuild
new file mode 100644
index 000000000000..f84c136e44bf
--- /dev/null
+++ b/gnome-base/gdm/gdm-2.6.0.9-r3.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/gdm-2.6.0.9-r3.ebuild,v 1.1 2005/06/05 15:05:46 foser Exp $
+
+inherit gnome2 eutils pam
+
+DESCRIPTION="GNOME2 Display Manager"
+HOMEPAGE="http://www.jirka.org/gdm.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips ~ppc64"
+IUSE="tcpd xinerama selinux ipv6 pam"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gentoo-gdm-theme-r2.tar.bz2"
+MY_V="${PV%.*}-openpam"
+
+RDEPEND="pam? ( virtual/pam )
+ !pam? ( sys-apps/shadow )
+ >=x11-libs/pango-1.4.1
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2
+ >=gnome-base/librsvg-2
+ >=media-libs/libart_lgpl-2.3.11
+ >=dev-libs/libxml2-2.4.12
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomecanvas-2
+ selinux? ( sys-libs/libselinux )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.3.11
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+G2CONF="${G2CONF} \
+ --sysconfdir=/etc/X11 \
+ --localstatedir=/var \
+ --with-pam-prefix=/etc \
+ --with-xdmcp \
+ `use_enable ipv6` \
+ `use_with tcpd tcp-wrappers` \
+ `use_with xinerama` \
+ `use_with selinux`"
+
+use pam && G2CONF="${G2CONF} --with-pam-prefix=/etc --enable-authentication=pam" \
+ || G2CONF="${G2CONF} --enable-console-helper=no --enable-authentication-scheme=shadow"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # remove unneeded linker directive for selinux (#41022)
+ epatch ${FILESDIR}/${PN}-2.4.4-selinux_remove_attr.patch
+ # fix ipv6 config
+ epatch ${FILESDIR}/${P}-ipv6_config.patch
+
+ autoconf || die
+
+}
+
+src_install() {
+
+ local pam_prefix
+
+ use pam && pam_prefix="PAM_PREFIX=${D}/etc"
+
+ gnome2_src_install \
+ ${pam_prefix} \
+ sysconfdir=${D}/etc/X11 \
+ localstatedir=${D}/var
+
+ # gdm-binary should be gdm to work with our init (#5598)
+ rm -f ${D}/usr/bin/gdm
+ mv ${D}/usr/bin/gdm-binary ${D}/usr/bin/gdm
+ dosym /usr/bin/gdm /usr/bin/gdm-binary
+
+ # log, etc.
+ keepdir /var/log/gdm
+ keepdir /var/gdm
+ chown root:gdm ${D}/var/gdm
+ chmod 1770 ${D}/var/gdm
+
+ # use our own session script
+ rm -f ${D}/etc/X11/gdm/Xsession
+ exeinto /etc/X11/gdm
+ doexe ${FILESDIR}/${MY_V}/Xsession
+
+ # add a custom xsession .desktop by default (#44537)
+ exeinto /etc/X11/dm/Sessions
+ doexe ${FILESDIR}/${MY_V}/custom.desktop
+
+ # We replace the pam stuff by our own
+ rm -f ${D}/etc/pam.d/gdm
+
+ dopamd ${FILESDIR}/${MY_V}/pam.d/*
+ dopamsecurity console.apps ${FILESDIR}/${MY_V}/security/console.apps/gdmconfig
+
+ # use graphical greeter local
+ dosed "s:#Greeter=/usr/bin/gdmlogin:Greeter=/usr/bin/gdmgreeter:" /etc/X11/gdm/gdm.conf
+
+ # Move Gentoo theme in
+ mv ${WORKDIR}/gentoo-* ${D}/usr/share/gdm/themes
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README* TODO
+
+}
+
+pkg_postinst() {
+
+ gnome2_pkg_postinst
+
+ # Soft restart, assumes Gentoo defaults for file locations
+ FIFOFILE=/var/gdm/.gdmfifo
+ PIDFILE=/var/run/gdm.pid
+ if [ -w ${FIFOFILE} ] ; then
+ if [ -f ${PIDFILE} ] ; then
+ if kill -0 `cat ${PIDFILE}`; then
+ (echo;echo SOFT_RESTART) >> ${FIFOFILE}
+ fi
+ fi
+ fi
+
+ einfo "To make GDM start at boot, edit /etc/rc.conf"
+ einfo "and then execute 'rc-update add xdm default'."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+
+ einfo "To remove GDM from startup please execute"
+ einfo "'rc-update del xdm default'"
+
+}