summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-01-09 23:29:05 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-01-09 23:29:05 +0000
commit32d2ac38fc430f66cd17a8804ddd2b16e6e741d6 (patch)
tree56bb465a7d5b1b9f6cf869a0574f924a4a684660 /games-util/biounzip/biounzip-1.1a.ebuild
parenttypo (diff)
downloadhistorical-32d2ac38fc430f66cd17a8804ddd2b16e6e741d6.tar.gz
historical-32d2ac38fc430f66cd17a8804ddd2b16e6e741d6.tar.bz2
historical-32d2ac38fc430f66cd17a8804ddd2b16e6e741d6.zip
Initial import. Ebuild by Constantin Bergemann <tony@knueppelcore.de>.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'games-util/biounzip/biounzip-1.1a.ebuild')
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
new file mode 100644
index 000000000000..39916176f51a
--- /dev/null
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/biounzip/biounzip-1.1a.ebuild,v 1.1 2006/01/09 23:29:05 wolf31o2 Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${P/a/}"
+
+DESCRIPTION="Unpacks BioZip archives"
+HOMEPAGE="http://biounzip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biounzip/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/libc sys-libs/zlib"
+
+src_compile() {
+ sed -i -e "s#-march=athlon-xp#${CFLAGS}#" Makefile
+ emake
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe biounzip
+ dodoc biozip.txt
+}
+