summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-03-01 14:49:14 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-03-01 14:49:14 +0000
commit230404b83a6fdaf0a704c0fa4b745156bbef0ceb (patch)
treea954c48b71680ea3248d7cd804f5bf726bcc7c33 /games-util/antimicro/antimicro-2.1.ebuild
parentsign (diff)
downloadhistorical-230404b83a6fdaf0a704c0fa4b745156bbef0ceb.tar.gz
historical-230404b83a6fdaf0a704c0fa4b745156bbef0ceb.tar.bz2
historical-230404b83a6fdaf0a704c0fa4b745156bbef0ceb.zip
version bump
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xBDEED020
Diffstat (limited to 'games-util/antimicro/antimicro-2.1.ebuild')
-rw-r--r--games-util/antimicro/antimicro-2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-util/antimicro/antimicro-2.1.ebuild b/games-util/antimicro/antimicro-2.1.ebuild
new file mode 100644
index 000000000000..538674659ce4
--- /dev/null
+++ b/games-util/antimicro/antimicro-2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/antimicro/antimicro-2.1.ebuild,v 1.1 2014/03/01 14:49:14 hasufell Exp $
+
+EAPI=5
+inherit eutils qmake-utils
+
+DESCRIPTION="Map keyboard and mouse buttons to gamepad buttons"
+HOMEPAGE="https://github.com/Ryochan7/antimicro"
+SRC_URI="https://github.com/Ryochan7/antimicro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/libsdl:0[joystick]
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/src
+
+src_configure() {
+ eqmake4 INSTALL_PREFIX="${D%/}"/usr antimicro.pro
+}
+
+src_compile() {
+ emake
+ emake updateqm
+}