summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-06 09:26:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-06 09:26:41 +0000
commitd107ea7fa7aece11b063d6f2fa9843892d2433f8 (patch)
treeb588c1e6569837737d0aa54dc74ec6677611b8c8 /games-strategy
parentversion bump (bug #40458) (diff)
downloadhistorical-d107ea7fa7aece11b063d6f2fa9843892d2433f8.tar.gz
historical-d107ea7fa7aece11b063d6f2fa9843892d2433f8.tar.bz2
historical-d107ea7fa7aece11b063d6f2fa9843892d2433f8.zip
version bump (bug #40458)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.6.99.21
-rw-r--r--games-strategy/wesnoth/wesnoth-0.6.99.2.ebuild36
3 files changed, 39 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 3c60deaf1684..b66f06a765d4 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,11 +1,11 @@
MD5 15da46914c18a71422e2cde7d225a9c6 wesnoth-0.4.8.ebuild 1042
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 75ad9b4d455793c63642040710d35afc ChangeLog 1376
+MD5 a01b41603a4cff92a8d3218fe4186956 ChangeLog 1521
MD5 523e7508fde512b80444bdf35bf999b7 wesnoth-0.5.1.ebuild 1086
MD5 8095bf0449b4c25a1f918c5bc30b3a16 wesnoth-0.5.ebuild 1191
MD5 93568e78956478a481244d3dc74cbe5e wesnoth-0.6.1.ebuild 893
MD5 f5d5b6d1503a3ba1e0b070681ad7b902 wesnoth-0.6.99.1.ebuild 918
-MD5 f5d5b6d1503a3ba1e0b070681ad7b902 wesnoth-0.6.99.2.ebuild 918
+MD5 d341487bf607c02fa430fb1650f842dd wesnoth-0.6.99.2.ebuild 918
MD5 12449f4d45609424ab20eb79f5f77baf files/digest-wesnoth-0.4.8 66
MD5 906d61f6bd37904556d48a72fd3d7e7f files/digest-wesnoth-0.5 65
MD5 d5ad9b90f362470f8749bf69f17eb378 files/digest-wesnoth-0.5.1 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.6.99.2 b/games-strategy/wesnoth/files/digest-wesnoth-0.6.99.2
new file mode 100644
index 000000000000..2f35cff15783
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.6.99.2
@@ -0,0 +1 @@
+MD5 a83d8dba520ab302fa828adeb8192261 wesnoth-0.6.99.2.tar.gz 15812378
diff --git a/games-strategy/wesnoth/wesnoth-0.6.99.2.ebuild b/games-strategy/wesnoth/wesnoth-0.6.99.2.ebuild
new file mode 100644
index 000000000000..e6f68d46b217
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.6.99.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.6.99.2.ebuild,v 1.1 2004/02/06 09:26:34 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc"
+IUSE="server editor tools"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ `use_enable server` \
+ `use_enable editor` \
+ `use_enable tools` \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}