summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-03-02 07:58:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-03-02 07:58:09 +0000
commit84d4296392e8fd98d23cb10c219979278687db3e (patch)
tree7b570da1a9e035e364eec27c5b74d2c99ae08a77 /games-strategy/boswars/boswars-2.5.ebuild
parentadd pkgconfig dep (bug #206126) (diff)
downloadhistorical-84d4296392e8fd98d23cb10c219979278687db3e.tar.gz
historical-84d4296392e8fd98d23cb10c219979278687db3e.tar.bz2
historical-84d4296392e8fd98d23cb10c219979278687db3e.zip
version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-strategy/boswars/boswars-2.5.ebuild')
-rw-r--r--games-strategy/boswars/boswars-2.5.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-strategy/boswars/boswars-2.5.ebuild b/games-strategy/boswars/boswars-2.5.ebuild
new file mode 100644
index 000000000000..7c89d58d4c9c
--- /dev/null
+++ b/games-strategy/boswars/boswars-2.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.1 2008/03/02 07:58:08 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Futuristic real-time strategy game"
+HOMEPAGE="http://www.boswars.org/"
+SRC_URI="http://www.boswars.org/dist/releases/${P}-src.tar.gz
+ mirror://gentoo/bos.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ media-libs/libsdl
+ media-libs/libpng
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/libogg
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A/bos.png}
+ cd "${S}"
+ rm -f doc/{README-SDL.txt,guichan-copyright.txt}
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ engine/include/stratagus.h \
+ || die "sed failed"
+}
+
+src_compile() {
+ scons || die "scons failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns graphics intro languages maps scripts sounds units \
+ || die "doins failed"
+ doicon "${DISTDIR}"/bos.png
+ make_desktop_entry ${PN} "Bos Wars" bos
+ dodoc CHANGELOG COPYRIGHT.txt README.txt
+ dohtml -r doc/*
+ prepgamesdirs
+}