summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-11 21:42:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-11 21:42:40 +0000
commitaf6f74a8065e2855a9b68f3db956831cb4ebf600 (patch)
treeeb005ed74e1942bcf7aa35d524bab577c9ef0ef3 /games-sports
parentMask off gcc-4 before it goes ~x86, as it is not yet good for SSP. (diff)
downloadhistorical-af6f74a8065e2855a9b68f3db956831cb4ebf600.tar.gz
historical-af6f74a8065e2855a9b68f3db956831cb4ebf600.tar.bz2
historical-af6f74a8065e2855a9b68f3db956831cb4ebf600.zip
tidy
Package-Manager: portage-2.0.53
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/gracer/ChangeLog7
-rw-r--r--games-sports/gracer/Manifest6
-rw-r--r--games-sports/gracer/gracer-0.1.5.ebuild33
3 files changed, 24 insertions, 22 deletions
diff --git a/games-sports/gracer/ChangeLog b/games-sports/gracer/ChangeLog
index b9cc0891b73a..f78a6f71db07 100644
--- a/games-sports/gracer/ChangeLog
+++ b/games-sports/gracer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-sports/gracer
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.11 2005/09/26 18:22:15 wolf31o2 Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.12 2006/01/11 21:42:40 mr_bones_ Exp $
+
+ 11 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> gracer-0.1.5.ebuild:
+ tidy
26 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org> gracer-0.1.5.ebuild:
Making games last on inherit line.
diff --git a/games-sports/gracer/Manifest b/games-sports/gracer/Manifest
index 87cc6558e426..cae0b499601b 100644
--- a/games-sports/gracer/Manifest
+++ b/games-sports/gracer/Manifest
@@ -1,6 +1,6 @@
-MD5 9c7d9e69935c2e2118ee99aeaae67b50 gracer-0.1.5.ebuild 1258
-MD5 5508bfd641572ad914e21efbca9a8c52 ChangeLog 1270
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 ca94811c0de248f067d57c1cf26e316e ChangeLog 1355
MD5 f978345d5296e011b2bfbd03e2820588 files/0.1.5-gldefs.patch 1068
MD5 7d4c79d23fc5bab84c8ebb7f8a295f6c files/digest-gracer-0.1.5 64
MD5 24914a3740a023f755f840b31eba9a98 files/gracer-gcc-3.4.patch 1755
+MD5 e46ce75783bf4c69bce18671bd63f87b gracer-0.1.5.ebuild 1196
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
diff --git a/games-sports/gracer/gracer-0.1.5.ebuild b/games-sports/gracer/gracer-0.1.5.ebuild
index 6fbf15064976..3b35df956121 100644
--- a/games-sports/gracer/gracer-0.1.5.ebuild
+++ b/games-sports/gracer/gracer-0.1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.11 2005/09/26 18:22:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.12 2006/01/11 21:42:40 mr_bones_ Exp $
inherit gnuconfig eutils games
@@ -10,10 +10,10 @@ SRC_URI="mirror://sourceforge/gracer/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc ~amd64 ppc"
+KEYWORDS="~amd64 ppc sparc x86"
IUSE="gif jpeg png joystick"
-RDEPEND="virtual/x11
+DEPEND="virtual/x11
virtual/glu
virtual/glut
virtual/opengl
@@ -22,32 +22,31 @@ RDEPEND="virtual/x11
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )
media-libs/plib"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/${PV}-gldefs.patch"
- epatch ${FILESDIR}/${PN}-gcc-3.4.patch
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${PV}-gldefs.patch
+ "${FILESDIR}"/${PN}-gcc-3.4.patch
}
src_compile() {
gnuconfig_update
egamesconf \
- `use_enable joystick` \
- `use_enable gif` \
- `use_enable jpeg` \
- `use_enable png` \
- || die
+ $(use_enable joystick) \
+ $(use_enable gif) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ || die
sed -i \
- -e 's:-lplibsl:-lplibsl -lplibul:' `find -name Makefile` \
+ -e 's:-lplibsl:-lplibsl -lplibul:' $(find -name Makefile) \
|| die "sed Makefiles failed"
emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
prepgamesdirs
}