summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-01 22:09:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-01 22:09:55 +0000
commit10d5ec9d7710be0fb633df9c4d01782f3ac45d35 (patch)
tree9f8d04234ac832b59113d3dd7a55ff49ce45230c /games-simulation/qct/qct-0.7.ebuild
parenttypo fix #46526 (diff)
downloadhistorical-10d5ec9d7710be0fb633df9c4d01782f3ac45d35.tar.gz
historical-10d5ec9d7710be0fb633df9c4d01782f3ac45d35.tar.bz2
historical-10d5ec9d7710be0fb633df9c4d01782f3ac45d35.zip
initial commit; ebuild submitted by Alexandru Toma via bug #46472
Diffstat (limited to 'games-simulation/qct/qct-0.7.ebuild')
-rw-r--r--games-simulation/qct/qct-0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-simulation/qct/qct-0.7.ebuild b/games-simulation/qct/qct-0.7.ebuild
new file mode 100644
index 000000000000..4a59046b0647
--- /dev/null
+++ b/games-simulation/qct/qct-0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.1 2004/04/01 22:09:55 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
+HOMEPAGE="http://sourceforge.net/projects/qct/"
+SRC_URI="mirror://sourceforge/qct/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.2.1
+ >=dev-python/pygame-1.5.5"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ local destdir="${GAMES_DATADIR}/${PN}"
+ insinto "${destdir}"
+ exeinto "${destdir}"
+
+ dodoc README
+ doins *.py *.png
+ doexe qct.py
+
+ games_make_wrapper qct "./qct.py" "${destdir}"
+
+ prepgamesdirs
+}