summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-03-07 08:22:52 +0000
committerRoy Marples <uberlord@gentoo.org>2006-03-07 08:22:52 +0000
commitdf0f7f41d85f68d5f680d527fcba8b424ea249fe (patch)
treed7505bf805475ff7cc2ee2eb24f6198d57c171b6 /games-rpg/eternal-lands-data
parentstable on x86, for various fixes (diff)
downloadhistorical-df0f7f41d85f68d5f680d527fcba8b424ea249fe.tar.gz
historical-df0f7f41d85f68d5f680d527fcba8b424ea249fe.tar.bz2
historical-df0f7f41d85f68d5f680d527fcba8b424ea249fe.zip
Renamed stonebrick1.E3D to stonebrick1.e3d which fixes badobject being shown on some textures. Thanks to Daniel Nilsson for the patch.
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'games-rpg/eternal-lands-data')
-rw-r--r--games-rpg/eternal-lands-data/ChangeLog9
-rw-r--r--games-rpg/eternal-lands-data/eternal-lands-data-1.2.0_p1-r1.ebuild59
-rw-r--r--games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.2.0_p1-r16
3 files changed, 73 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands-data/ChangeLog b/games-rpg/eternal-lands-data/ChangeLog
index 2711e1a57cad..0e73b1c39074 100644
--- a/games-rpg/eternal-lands-data/ChangeLog
+++ b/games-rpg/eternal-lands-data/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-rpg/eternal-lands-data
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.1 2006/02/13 20:44:45 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.2 2006/03/07 08:22:50 uberlord Exp $
+
+*eternal-lands-data-1.2.0_p1-r1 (07 Mar 2006)
+
+ 07 Mar 2006; Roy Marples <uberlord@gentoo.org>
+ +eternal-lands-data-1.2.0_p1-r1.ebuild:
+ Renamed stonebrick1.E3D to stonebrick1.e3d which fixes badobject
+ being shown on some textures. Thanks to Daniel Nilsson for the patch.
*eternal-lands-data-1.2.0_p1 (13 Feb 2006)
diff --git a/games-rpg/eternal-lands-data/eternal-lands-data-1.2.0_p1-r1.ebuild b/games-rpg/eternal-lands-data/eternal-lands-data-1.2.0_p1-r1.ebuild
new file mode 100644
index 000000000000..ed9c1d985779
--- /dev/null
+++ b/games-rpg/eternal-lands-data/eternal-lands-data-1.2.0_p1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/eternal-lands-data-1.2.0_p1-r1.ebuild,v 1.1 2006/03/07 08:22:51 uberlord Exp $
+
+inherit games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+MY_PN="${PN%*-data}"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://www.other-life.com/el/el_${MY_PV}_linux_full.zip
+ music? ( mirror://gentoo/el_music_${MY_PV}.zip )"
+# WARNING: The music file is held at
+# http://www.other-life.com/downloads/music.zip
+# We only mirror it so that it is versioned AND prefixed with el_ so as not
+# cause any conflicts.
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="music"
+
+DEPEND="app-arch/unzip
+ sys-apps/findutils"
+
+src_unpack() {
+ cd "${WORKDIR}"
+ unpack ${A}
+ use music && mv *.ogg *.pll music
+
+ # This file has the wrong name, #125302
+ mv 3dobjects/misc_objects/stonebrick1.E3D \
+ 3dobjects/misc_objects/stonebrick1.e3d
+}
+
+src_install() {
+ cd "${WORKDIR}"
+
+ # These are provided by eternal-lands ebuild
+ rm mapinfo.lst license.txt
+
+ insinto "${GAMES_DATADIR}/${MY_PN}"
+ doins -r 2dobjects 3dobjects animations maps meshes music particles \
+ skeletons sound textures tiles \
+ *.lst 3dobjects.txt \
+ || die "doins failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${MY_PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${MY_PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.2.0_p1-r1 b/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.2.0_p1-r1
new file mode 100644
index 000000000000..1efb181e88ed
--- /dev/null
+++ b/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.2.0_p1-r1
@@ -0,0 +1,6 @@
+MD5 010cc9b69efcd3487d96c1de8562de1f el_120p1_linux_full.zip 37718170
+RMD160 7aca051372b5cebc8349b46d26278d9d49835a13 el_120p1_linux_full.zip 37718170
+SHA256 4d3128efee1469f0a2b9f1c7dfce0d9621d54d8ef6e689057bd460957a2e4792 el_120p1_linux_full.zip 37718170
+MD5 4323ef5cb27937ead1e4325979afdf41 el_music_120p1.zip 29525350
+RMD160 0f42d35e1dab0fc5c38c8457ff268c07b4497363 el_music_120p1.zip 29525350
+SHA256 682b8d304a4a7374742a575bf79dc60adc764ad6e8d1a9ed6e0df3de5f7cd2af el_music_120p1.zip 29525350