summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2007-12-29 03:16:05 +0000
committerRichard Freeman <rich0@gentoo.org>2007-12-29 03:16:05 +0000
commit178fae03ab69e5d7fed49e24045eda647f0adc3a (patch)
tree3c401150671b7659a7b66cbe4a83f1e1230c49ae /games-rpg/eternal-lands-data/eternal-lands-data-1.5.0.ebuild
parentAdd sound useflag for games-rpg/eternal-lands-data. (diff)
downloadhistorical-178fae03ab69e5d7fed49e24045eda647f0adc3a.tar.gz
historical-178fae03ab69e5d7fed49e24045eda647f0adc3a.tar.bz2
historical-178fae03ab69e5d7fed49e24045eda647f0adc3a.zip
Version bump - #201161
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'games-rpg/eternal-lands-data/eternal-lands-data-1.5.0.ebuild')
-rw-r--r--games-rpg/eternal-lands-data/eternal-lands-data-1.5.0.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/games-rpg/eternal-lands-data/eternal-lands-data-1.5.0.ebuild b/games-rpg/eternal-lands-data/eternal-lands-data-1.5.0.ebuild
new file mode 100644
index 000000000000..6c39a0579ec3
--- /dev/null
+++ b/games-rpg/eternal-lands-data/eternal-lands-data-1.5.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/eternal-lands-data-1.5.0.ebuild,v 1.1 2007/12/29 03:12:24 rich0 Exp $
+
+inherit games
+
+MUSIC_DATE="20060803"
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+MY_PN="${PN%*-data}"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://el.beplacid.net/downloads/elc_150_linux.zip
+ music? ( mirror://gentoo/el_music_full-${MUSIC_DATE}.zip )
+ sound? ( mirror://gentoo/el_sound_150.zip )"
+# WARNING: The music file is held at
+# http://www.eternal-lands.com/page/music.php
+# We only mirror it so that it is versioned by the date we mirrored it
+# AND prefixed with el_ so as not cause any conflicts. Maybe oneday they will
+# version their music, maybe not.
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="music sound"
+
+DEPEND="app-arch/unzip"
+
+# Maybe one day upstream will do things in a consistent way.
+S="${WORKDIR}/elc-150"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Move our music files to the correct directory
+ if use music ; then
+ mv ../*.ogg ../*.pll music || die
+ fi
+}
+
+src_install() {
+ # These are provided by eternal-lands ebuild
+
+ rm license.txt
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${MY_PN}"
+ doins -r 2dobjects 3dobjects actor_defs animations maps meshes music \
+ particles skeletons textures tiles languages \
+ *.lst 3dobjects.txt *.xml \
+ || die "doins failed"
+
+ # Removed sound from above - need to handle sound support
+
+ cd "${WORKDIR}"
+ if use sound ; then
+ doins -r sound || die "doins sound failed"
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${MY_PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${MY_PN}" -type d -exec chmod g+sx {} \;
+}