summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-06 07:46:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-06 07:46:34 +0000
commit79f6ecc6b5c47bac30b3e02e34540c0d5163f32c (patch)
tree64d78038473aa07c5ec6a1c674166e9cbe21e0c6 /games-roguelike
parentversion bump (bug #51874) (diff)
downloadhistorical-79f6ecc6b5c47bac30b3e02e34540c0d5163f32c.tar.gz
historical-79f6ecc6b5c47bac30b3e02e34540c0d5163f32c.tar.bz2
historical-79f6ecc6b5c47bac30b3e02e34540c0d5163f32c.zip
version bump (bug #51896)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/angband/ChangeLog7
-rw-r--r--games-roguelike/angband/Manifest4
-rw-r--r--games-roguelike/angband/angband-3.0.5.ebuild55
-rw-r--r--games-roguelike/angband/files/digest-angband-3.0.51
4 files changed, 65 insertions, 2 deletions
diff --git a/games-roguelike/angband/ChangeLog b/games-roguelike/angband/ChangeLog
index 0a7dcf24de95..8060ff90e44e 100644
--- a/games-roguelike/angband/ChangeLog
+++ b/games-roguelike/angband/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/angband
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/ChangeLog,v 1.6 2004/03/31 06:39:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/ChangeLog,v 1.7 2004/06/06 07:46:34 mr_bones_ Exp $
+
+*angband-3.0.5 (06 Jun 2004)
+
+ 06 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> angband-3.0.5.ebuild:
+ version bump (bug #51896)
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> angband-3.0.3.ebuild:
don't RDEPEND on sed; error check sed; virtual/x11; tidy
diff --git a/games-roguelike/angband/Manifest b/games-roguelike/angband/Manifest
index b81bbda32aae..fef7a30ac796 100644
--- a/games-roguelike/angband/Manifest
+++ b/games-roguelike/angband/Manifest
@@ -1,6 +1,8 @@
-MD5 2f8d6a0dff10d16dd50668868ac604ea ChangeLog 1373
+MD5 1b92fb8bec1bc74b3b25dabe2e132fff ChangeLog 1508
MD5 41132cd5069f1064525d096b225b422e angband-3.0.4.ebuild 1448
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 901a26e27d4a2b62becc3ec9f871487f angband-3.0.3.ebuild 1163
+MD5 5b76c880c0bc3868a8dd87d05d710425 angband-3.0.5.ebuild 1297
MD5 166bf6a071476d096a14cc12f5c634f9 files/digest-angband-3.0.3 66
MD5 ae920fa25b66efac2f0afe50fc92f2fb files/digest-angband-3.0.4 66
+MD5 664ca676ca11ddb5e8c75f01ed3d89cf files/digest-angband-3.0.5 66
diff --git a/games-roguelike/angband/angband-3.0.5.ebuild b/games-roguelike/angband/angband-3.0.5.ebuild
new file mode 100644
index 000000000000..07a3fdac8845
--- /dev/null
+++ b/games-roguelike/angband/angband-3.0.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/angband-3.0.5.ebuild,v 1.1 2004/06/06 07:46:34 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R.Tolkien"
+HOMEPAGE="http://thangorodrim.net/"
+SRC_URI="ftp://clockwork.dementia.org/${PN}/Source/${P}.tar.gz"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="X gtk"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5
+ gtk? (
+ =x11-libs/gtk+-1.2*
+ dev-libs/glib
+ virtual/x11
+ )
+ X? ( virtual/x11 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:/games/:/:" configure \
+ || die "sed configure failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --bindir="${GAMES_BINDIR}" \
+ --with-setgid="${GAMES_GROUP}" \
+ $(use_enable gtk) \
+ $(use_with X x) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS THANKS TODO changes.txt compile.txt readme.txt
+ find "${D}${GAMES_DATADIR}" -type f -exec chmod a-x \{\} \;
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ chmod -R g+w "${ROOT}${GAMES_DATADIR}"/angband/lib/{apex,save,user}
+}
diff --git a/games-roguelike/angband/files/digest-angband-3.0.5 b/games-roguelike/angband/files/digest-angband-3.0.5
new file mode 100644
index 000000000000..8dba1f0cf1fb
--- /dev/null
+++ b/games-roguelike/angband/files/digest-angband-3.0.5
@@ -0,0 +1 @@
+MD5 cc61e55baf4ffdcf9bfc6caa14935ec0 angband-3.0.5.tar.gz 1496319