summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-10 09:39:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-10 09:39:36 +0000
commit0fb0965c37c03a5dd49b1647c323b9a87d8f0df8 (patch)
tree0467af4eccd9e92dba410cf7dd4ba6716d3e42e8 /games-roguelike
parentadd app-i18n/uim-svn:m17n-lib (diff)
downloadhistorical-0fb0965c37c03a5dd49b1647c323b9a87d8f0df8.tar.gz
historical-0fb0965c37c03a5dd49b1647c323b9a87d8f0df8.tar.bz2
historical-0fb0965c37c03a5dd49b1647c323b9a87d8f0df8.zip
Work around buggy makefiles so we get to use emake; Set DEF_PAGER from $PAGER (bug #52122); Use ${GAMES_STATEDIR} saving code in games.eclass instead of hacking it in the ebuild; Error check ; tidy
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/nethack/ChangeLog12
-rw-r--r--games-roguelike/nethack/Manifest4
-rw-r--r--games-roguelike/nethack/files/digest-nethack-3.4.3-r11
-rw-r--r--games-roguelike/nethack/nethack-3.4.3-r1.ebuild171
4 files changed, 186 insertions, 2 deletions
diff --git a/games-roguelike/nethack/ChangeLog b/games-roguelike/nethack/ChangeLog
index 5d16b193c62b..a1b8ca01afc6 100644
--- a/games-roguelike/nethack/ChangeLog
+++ b/games-roguelike/nethack/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for games-roguelike/nethack
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.8 2004/06/24 23:13:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.9 2004/07/10 09:39:36 mr_bones_ Exp $
+
+*nethack-3.4.3-r1 (10 Jul 2004)
+
+ 10 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +nethack-3.4.3-r1.ebuild:
+ Work around buggy makefiles so we get to use emake
+ Set DEF_PAGER from $PAGER (bug #52122)
+ Use ${GAMES_STATEDIR} saving code in games.eclass instead of hacking it
+ in the ebuild.
+ Error check ; tidy
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> nethack-3.4.2.ebuild,
nethack-3.4.3.ebuild:
diff --git a/games-roguelike/nethack/Manifest b/games-roguelike/nethack/Manifest
index 2794fa0dcb21..65e4c11e8714 100644
--- a/games-roguelike/nethack/Manifest
+++ b/games-roguelike/nethack/Manifest
@@ -1,4 +1,5 @@
-MD5 4c7823366dd55eb33433e7157ff17517 ChangeLog 3764
+MD5 7634cb57cbb9440a280618cd533b3414 ChangeLog 4088
+MD5 d5693ec9cdda4d6e5af3e6ab9dd91359 nethack-3.4.3-r1.ebuild 4819
MD5 da9d8f30514e190e06fff0891b410cfd nethack-3.4.2.ebuild 4240
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 965b88bdac6ad16fd4f96dcb25a0144c nethack-3.4.3.ebuild 4251
@@ -9,6 +10,7 @@ MD5 68200eaa7e6d116868700aab23e7e1d5 files/3.4.3-X-support.patch 920
MD5 b4d0d816b1b1f1977abb48258913cf4e files/3.4.3-default-options.patch 1262
MD5 a33605f7cde87f4aafa5c42998a9feb2 files/3.4.3-gentoo-paths.patch 576
MD5 ed68fbd43d4e591eee4930aa4578a012 files/digest-nethack-3.4.3 65
+MD5 ed68fbd43d4e591eee4930aa4578a012 files/digest-nethack-3.4.3-r1 65
MD5 7dfa79bba03a240cb7bba2e84d8178ef files/3.4.2-GNOME-support.patch 1316
MD5 004669e4ce554b5f7f92daaea2e2cebb files/3.4.2-QT-GNOME-support.patch 1507
MD5 a3d1ce8c6361062550228c955608f057 files/3.4.2-QT-support.patch 1137
diff --git a/games-roguelike/nethack/files/digest-nethack-3.4.3-r1 b/games-roguelike/nethack/files/digest-nethack-3.4.3-r1
new file mode 100644
index 000000000000..ba80af888282
--- /dev/null
+++ b/games-roguelike/nethack/files/digest-nethack-3.4.3-r1
@@ -0,0 +1 @@
+MD5 21479c95990eefe7650df582426457f9 nethack-343-src.tgz 3497458
diff --git a/games-roguelike/nethack/nethack-3.4.3-r1.ebuild b/games-roguelike/nethack/nethack-3.4.3-r1.ebuild
new file mode 100644
index 000000000000..d9348e586dca
--- /dev/null
+++ b/games-roguelike/nethack/nethack-3.4.3-r1.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.3-r1.ebuild,v 1.1 2004/07/10 09:39:36 mr_bones_ Exp $
+
+inherit eutils gcc flag-o-matic games
+
+MY_PV=${PV//.}
+DESCRIPTION="The ultimate old-school single player dungeon exploration game"
+HOMEPAGE="http://www.nethack.org/"
+SRC_URI="mirror://sourceforge/nethack/${PN}-${MY_PV}-src.tgz"
+#SRC_URI="ftp://ftp.nethack.org/pub/nethack/nh340/src/nethack-340.tgz"
+
+LICENSE="nethack"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="X qt gnome"
+
+DEPEND="virtual/libc
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2-r5
+ X? ( virtual/x11 )
+ qt? ( x11-libs/qt )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.4-r2 )"
+
+HACKDIR="${GAMES_DATADIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ # This copies the /sys/unix Makefile.*s to their correct places for
+ # seding and compiling.
+ cd "${S}/sys/unix"
+ source setup.sh || die
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
+ epatch "${FILESDIR}/${PV}-default-options.patch"
+
+ sed -i \
+ -e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h \
+ || die "setting statedir"
+ sed -i \
+ -e "s:GENTOO_HACKDIR:${HACKDIR}:" include/config.h \
+ || die "seting hackdir"
+ # set the default pager from the environment bug #52122
+ if [ -n "${PAGER}" ] ; then
+ sed -i \
+ -e "115c\#define DEF_PAGER \"${PAGER}\"" \
+ include/unixconf.h \
+ || die "setting statedir"
+ fi
+
+ if use X ; then
+ epatch "${FILESDIR}/${PV}-X-support.patch"
+ if use qt ; then
+ epatch "${FILESDIR}/${PV}-QT-support.patch"
+ use gnome && epatch "${FILESDIR}/${PV}-QT-GNOME-support.patch"
+ elif use gnome ; then
+ epatch "${FILESDIR}/${PV}-GNOME-support.patch"
+ fi
+ fi
+}
+
+src_compile() {
+ local qtver=
+
+ has_version =x11-libs/qt-3* \
+ && qtver=3 \
+ || qtver=2
+ cd ${S}/src
+ append-flags -I../include
+
+ emake \
+ QTDIR=/usr/qt/${qtver} \
+ CC="$(gcc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LFLAGS="-L/usr/X11R6/lib" \
+ ../util/makedefs \
+ || die "initial makedefs build failed"
+ emake \
+ QTDIR=/usr/qt/${qtver} \
+ CC="$(gcc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LFLAGS="-L/usr/X11R6/lib" \
+ || die "main build failed"
+ cd ${S}/util
+ emake CFLAGS="${CFLAGS}" recover || die "util build failed"
+}
+
+src_install() {
+ make \
+ CC="$(gcc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LFLAGS="-L/usr/X11R6/lib" \
+ GAMEPERM=0755 \
+ PREFIX="${D}/usr" \
+ GAMEDIR="${D}${HACKDIR}" \
+ SHELLDIR="${D}/${GAMES_BINDIR}" \
+ install \
+ || die "make install failed"
+
+ # We keep this stuff in ${GAMES_STATEDIR} instead so tidy up.
+ rm -rf "${D}/usr/share/games/nethack/save"
+
+ newgamesbin util/recover recover-nethack || die "newgamesbin failed"
+
+ # The final nethack is a sh script. This fixes the hard-coded
+ # HACKDIR directory so it doesn't point to ${D}/usr/share/nethackdir
+ sed -i \
+ -e "s:^\(HACKDIR=\).*:\1${HACKDIR}:" \
+ "${D}${GAMES_BINDIR}/nethack" \
+ || die "sed ${D}${GAMES_BINDIR}/nethack failed"
+
+ doman doc/*.6
+ dodoc doc/*.txt
+
+ # Can be copied to ~/.nethackrc to set options
+ # Add this to /etc/.skel as well, thats the place for default configs
+ insinto "${HACKDIR}"
+ doins "${FILESDIR}/dot.nethackrc"
+
+ local windowtypes="tty"
+ use gnome && windowtypes="${windowtypes} gnome"
+ use qt && windowtypes="${windowtypes} qt"
+ use X && windowtypes="${windowtypes} x11"
+ set -- ${windowtypes}
+ sed -i \
+ -e "s:GENTOO_WINDOWTYPES:${windowtypes}:" \
+ -e "s:GENTOO_DEFWINDOWTYPE:$1:" \
+ "${D}${HACKDIR}/dot.nethackrc" \
+ || die "sed ${D}${HACKDIR}/dot.nethackrc failed"
+ insinto /etc/skel
+ newins "${D}/${HACKDIR}/dot.nethackrc" .nethackrc
+
+ if use X ; then
+ # install nethack fonts
+ cd "${S}/win/X11"
+ bdftopcf -o nh10.pcf nh10.bdf || die "Converting fonts failed"
+ bdftopcf -o ibm.pcf ibm.bdf || die "Converting fonts failed"
+ insinto "${HACKDIR}/fonts"
+ doins *.pcf
+ cd "${D}/${HACKDIR}/fonts"
+ mkfontdir || die "The action mkfontdir ${D}${HACKDIR}/fonts failed"
+
+ # copy nethack x application defaults
+ cd "${S}/win/X11"
+ insinto /etc/X11/app-defaults
+ newins NetHack.ad NetHack || die "Failed to install NetHack X app defaults"
+ sed -i \
+ -e 's:^!\(NetHack.tile_file.*\):\1:' \
+ "${D}/etc/X11/app-defaults/NetHack" \
+ || die "sed ${D}/etc/X11/app-defaults/NetHack failed"
+ fi
+
+ local statedir="${GAMES_STATEDIR}/${PN}"
+ keepdir "${statedir}/save"
+ mv "${D}/${HACKDIR}/"{record,logfile,perm} "${D}/${statedir}/"
+
+ prepgamesdirs
+ chmod -R 660 "${D}/${statedir}"
+ chmod 770 "${D}/${statedir}" "${D}/${statedir}/save"
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use qt && has_version '=x11-libs/qt-3.1*' ; then
+ ewarn "the qt frontend may be a little unstable with this version of qt"
+ ewarn "please see Bug 32629 for more information"
+ fi
+ einfo "you may want to look at /etc/skel/.nethackrc for interesting options"
+}