summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 13:25:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 13:25:08 +0000
commit5f30328d4c906aba3d101592465c2eba918a790d (patch)
tree85b4d310f3ae6c94df63f031cf35d7cac23da430 /games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
parentheader fix (diff)
downloadhistorical-5f30328d4c906aba3d101592465c2eba918a790d.tar.gz
historical-5f30328d4c906aba3d101592465c2eba918a790d.tar.bz2
historical-5f30328d4c906aba3d101592465c2eba918a790d.zip
add cvs version of configure which doesn't check for gnome since that isn't supported anymore. Should address bug #44686; removed gnome USE support; use emake
Diffstat (limited to 'games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild')
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild35
1 files changed, 22 insertions, 13 deletions
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
index 0cf8b5a507f6..592b598772af 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
@@ -1,26 +1,36 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild,v 1.2 2004/02/20 06:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild,v 1.3 2004/03/20 13:25:08 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="Client for the nethack-style but more in the line of UO"
HOMEPAGE="http://crossfire.real-time.com/"
-SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz
+ mirror://gentoo/${P}.configure.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
-IUSE="sdl gnome gtk alsa"
+IUSE="sdl gtk alsa"
DEPEND="virtual/x11
sdl? ( media-libs/libsdl
media-libs/sdl-image )
- gnome? ( gnome-base/gnome-libs
- media-libs/gdk-pixbuf )
- gtk? ( =x11-libs/gtk+-1* )
+ gtk? ( =x11-libs/gtk+-1.2*
+ dev-libs/glib
+ )
alsa? ( media-libs/alsa-lib )
- media-libs/libpng"
+ media-libs/libpng
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ unpack ${P}.configure.gz
+ mv ${P}.configure configure
+ chmod a+x configure
+}
src_compile() {
# bugs in configure script so we cant use `use_enable`
@@ -28,16 +38,15 @@ src_compile() {
use gtk || myconf="${myconf} --disable-gtk"
use sdl || myconf="${myconf} --disable-sdl"
use alsa || myconf="${myconf} --disable-alsa"
- has_version '>=media-libs/alsa-lib-0.9' && myconf="${myconf} --disable-alsa --disable-sound"
-# use gnome || myconf="${myconf} --disable-gnome"
+ has_version '>=media-libs/alsa-lib-0.9' \
+ && myconf="${myconf} --disable-alsa --disable-sound"
egamesconf ${myconf} || die
- make || die
+ emake || die "emake failed"
}
src_install() {
- egamesinstall mandir=${T} || die
+ egamesinstall mandir="${T}" || die
use gtk && newman gtk/gcfclient.man gcfclient.6
- use gnome && newman gnome/gnome-cfclient.man gnome-cfclient.6
newman x11/cfclient.man cfclient.6
dodoc CHANGES NOTES README TODO
prepgamesdirs