summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-01-10 03:15:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-01-10 03:15:52 +0000
commit87e6a0cc66c6bc274d3c66c971f0d0f18a2592a0 (patch)
tree416bfc62e4dc2cdb0bc61a4bde6334052834e1d5 /games-mud/tintin/tintin-2.00.8.ebuild
parentinitial commit. solving bug #285060. (diff)
downloadhistorical-87e6a0cc66c6bc274d3c66c971f0d0f18a2592a0.tar.gz
historical-87e6a0cc66c6bc274d3c66c971f0d0f18a2592a0.tar.bz2
historical-87e6a0cc66c6bc274d3c66c971f0d0f18a2592a0.zip
version bump
Package-Manager: portage-2.1.10.41/cvs/Linux i686
Diffstat (limited to 'games-mud/tintin/tintin-2.00.8.ebuild')
-rw-r--r--games-mud/tintin/tintin-2.00.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-mud/tintin/tintin-2.00.8.ebuild b/games-mud/tintin/tintin-2.00.8.ebuild
new file mode 100644
index 000000000000..8db3be81359e
--- /dev/null
+++ b/games-mud/tintin/tintin-2.00.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tintin/tintin-2.00.8.ebuild,v 1.1 2012/01/10 03:15:52 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="(T)he k(I)cki(N) (T)ickin d(I)kumud clie(N)t"
+HOMEPAGE="http://tintin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tintin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib
+ dev-libs/libpcre
+ sys-libs/readline
+ sys-libs/ncurses"
+
+S=${WORKDIR}/tt/src
+
+PATCHES=( "${FILESDIR}"/${P}-ldpermission.patch )
+
+src_install () {
+ dogamesbin tt++ || die "dogamesbin failed"
+ dodoc ../{CREDITS,FAQ,README,SCRIPTS,TODO,docs/*}
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "**** OLD TINTIN SCRIPTS ARE NOT 100% COMPATIBLE WITH THIS VERSION ****"
+ ewarn "read the README for more details."
+ echo
+}