summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 18:14:05 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 18:14:05 +0000
commit5ce29dab6b88b9202c19ea19f36ea07ca2f4a16f (patch)
treef83f1d87bba32c391118e84f21fa0335fd7f26a5 /games-misc/gnurobots/gnurobots-1.0d.ebuild
parentstable on x86/alpha (diff)
downloadhistorical-5ce29dab6b88b9202c19ea19f36ea07ca2f4a16f.tar.gz
historical-5ce29dab6b88b9202c19ea19f36ea07ca2f4a16f.tar.bz2
historical-5ce29dab6b88b9202c19ea19f36ea07ca2f4a16f.zip
games-misc
Diffstat (limited to 'games-misc/gnurobots/gnurobots-1.0d.ebuild')
-rw-r--r--games-misc/gnurobots/gnurobots-1.0d.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-misc/gnurobots/gnurobots-1.0d.ebuild b/games-misc/gnurobots/gnurobots-1.0d.ebuild
new file mode 100644
index 000000000000..f9bb117e82f7
--- /dev/null
+++ b/games-misc/gnurobots/gnurobots-1.0d.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/gnurobots-1.0d.ebuild,v 1.1 2003/09/10 18:14:05 vapier Exp $
+
+inherit games
+
+MY_P="${PN}-${PV/d/D}"
+DESCRIPTION="Game/diversion where you construct a program for a little robot then set him loose and watch him explore a world on his own"
+HOMEPAGE="http://www.gnu.org/directory/games/gnurobots.html"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="X"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="X? ( virtual/x11 )
+ dev-util/guile"
+
+src_compile() {
+ egamesconf || die
+ emake || die
+}
+
+src_install() {
+ dogamesbin src/{robots,xrobots,robots_logfile}
+
+ insinto ${GAMES_DATADIR}/${PN}/scheme
+ doins scheme/*.scm
+ insinto ${GAMES_DATADIR}/${PN}/maps
+ doins maps/*.map
+
+ dodoc doc/*
+
+ prepgamesdirs
+}